Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 212333 - Cannot run yum, yumex, software manager
Summary: Cannot run yum, yumex, software manager
Keywords:
Status: CLOSED DUPLICATE of bug 213963
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 5
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-26 12:04 UTC by Bill Gottlieb
Modified: 2014-01-21 22:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-25 20:12:49 UTC


Attachments (Terms of Use)
Exception from Software Manager (deleted)
2006-10-26 12:04 UTC, Bill Gottlieb
no flags Details
Other error received (deleted)
2006-11-17 02:36 UTC, Charles Ferguson
no flags Details
CompsException in Software Manager (deleted)
2007-01-25 19:58 UTC, Nicola
no flags Details

Description Bill Gottlieb 2006-10-26 12:04:46 UTC
Description of problem: Cannot run yum, yumex, software manager


Version-Release number of selected component (if applicable):


How reproducible: Every time


Steps to Reproduce:
1. Start yumex
2. Run yum update
3. Start Software Manager
  
Actual results:

Result from running "yum update":

[root@dicemaster bill]# yum update
rpmdb: lock_downgrade: Lock is no longer valid
error: cannot open Packages index using db3 - Invalid argument (22)
error: cannot open Packages database in /var/lib/rpm
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 80, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 177, in getOptionsConfig
    self.doConfigSetup(fn=opts.conffile, root=root)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 102, in
doConfigSetup
    self.conf = config.readMainConfig(fn, root)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 589, in readMainConfig
    vars['releasever'] = _getsysver(earlyconf.installroot, earlyconf.distroverpkg)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 689, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg)
TypeError: rpmdb open failed

Comment 1 Bill Gottlieb 2006-10-26 12:04:46 UTC
Created attachment 139454 [details]
Exception from Software Manager

Comment 2 Charles Ferguson 2006-11-17 02:34:26 UTC
My exception error
-----------------------------
Component: Software Manager
Summary: TBc7d02ae3 config.py:689:_getsysver:TypeError: rpmdb open failed

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 363, in ?
    main()
  File "/usr/sbin/pirut", line 358, in main
    pm = PackageManager()
  File "/usr/sbin/pirut", line 56, in __init__
    GraphicalYumBase.__init__(self, False)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 122, in __init__
    self.doConfigSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 102, in
doConfigSetup
    self.conf = config.readMainConfig(fn, root)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 589, in readMainConfig
    vars['releasever'] = _getsysver(earlyconf.installroot, earlyconf.distroverpkg)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 689, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg)
TypeError: rpmdb open failed

Local variables in innermost frame:
installroot: /
ts: <rpmUtils.transaction.TransactionWrapper instance at 0xb15f74c>
distroverpkg: redhat-release


Comment 3 Charles Ferguson 2006-11-17 02:36:38 UTC
Created attachment 141437 [details]
Other error received

Comment 4 Charles Ferguson 2006-12-02 12:30:54 UTC
(In reply to comment #3)
> Created an attachment (id=141437) [edit]
> Other error received
> 

I viewed other simular bugs and found 203233 had a "work-around" that allowed me
to run yum and get updates. 
rm -f /var/lib/rpm/__db* deleted a corrupted db.

Comment 5 Samuel Sieb 2006-12-03 21:30:53 UTC
I've run into this a couple of times too.  I just delete the _* files then run
"rpm --rebuilddb".  Unfortunately, this has been a longstanding issue with rpm,
although it does seem to be quite rare now.

Comment 6 Nicola 2007-01-25 19:58:06 UTC
Created attachment 146612 [details]
CompsException in Software Manager

Comment 7 Jeremy Katz 2007-01-25 20:12:49 UTC

*** This bug has been marked as a duplicate of 213963 ***


Note You need to log in before you can comment on or make changes to this bug.