Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2121 - telnet is unable to resolve hostnames
Summary: telnet is unable to resolve hostnames
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: telnet
Version: 6.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-11 09:28 UTC by Pekka Pietikäinen
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-04-11 21:21:03 UTC


Attachments (Terms of Use)

Description Pekka Pietikäinen 1999-04-11 09:28:53 UTC
connecting (pp):~ >telnet evil.netppl.fi
Trying 0.0.0.0...
Connected to evil.netppl.fi.
Escape character is '^]'.

Red Hat Linux release 5.9.7 (Starbuck)

(so it connects to localhost instead, works fine when
using a IP address)

here's the ltrace output
inet_aton("evil", 0xbffff65c)                     = 0
gethostbyname("evil")                             =
0x40145ab0
strncpy(0x08057a40, "evil.netppl.fi", 64)         =
0x08057a40
__bzero(0xbffff658, 16, 0xbffff6f8, 1, 0)         = 0
getservbyname(0x0805433e, 0x08054324, 0xbffff6f8, 1, 0) =
0x40145bd0
inet_ntoa(NULL)                                   =
"0.0.0.0"
printf("Trying %s...\r\n", "0.0.0.0"Trying 0.0.0.0...

Comment 1 Jeff Johnson 1999-04-11 21:21:59 UTC
Fixed in telnet-0.10-26.


Note You need to log in before you can comment on or make changes to this bug.