Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 211762 - Please upgrade gmp if possible and at least mpfr
Summary: Please upgrade gmp if possible and at least mpfr
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gmp
Version: 6
Hardware: All
OS: Linux
urgent
high
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact:
URL:
Whiteboard:
: 166450 199550 (view as bug list)
Depends On:
Blocks: 225809
TreeView+ depends on / blocked
 
Reported: 2006-10-22 09:01 UTC by Jakub Jelinek
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-06 15:03:47 UTC


Attachments (Terms of Use)
proposed gmp.spec changes (deleted)
2006-10-22 11:02 UTC, Jakub Jelinek
no flags Details | Diff

Description Jakub Jelinek 2006-10-22 09:01:41 UTC
GCC trunk (i.e. what will become GCC 4.3) requires (unconditionally) GMP 4.1+
(that's included in FC6/RHEL5 already), but also MPFR 2.2.0+ (which is not,
gmp-4.1.4 included in FC6 has much older mpfr).
As many people use Fedora Core (and/or RHEL) as a development OS, this means
they'll either have to build it themselves and tweak the configury to find it,
or use something that provides them.
gmp-4.2.0 and above (latest is gmp-4.2.1) doesn't include mpfr any longer,
it has to be downloaded separately from www.mpfr.org (where the latest version
is 2.2.0).

My suggestion would be to:
1) upgrade gmp in dist-fc7 to 4.2.1 and split of separate mpfr packages (mpfr and mpfr-devel, both multilib, include shared libraries in mpfr them)
2) for dist-fc6 and dist-5E just add mpfr-2.2.0.tar.bz2 into gmp-4.1.4-*.src.rpm,
build gmp in the spec file with --disable-mpfr, build afterwards mpfr-2.2.0 against the newly built gmp with --disable-shared and install both

I really think this is very urgent, both for FC6 and RHEL5, as otherwise we might
lose developers.

Comment 1 Jakub Jelinek 2006-10-22 11:02:54 UTC
Created attachment 139076 [details]
proposed gmp.spec changes

These are proposed changes in gmp.spec for dist-fc6-updates/dist-5E.
The only thing I'm not sure what to do about is mpfrxx.h (this header is no
longer included in gmp-2.0+ and was never part if mpfr itself.
Is there anything that uses mpfrxx.h?  If yes, it depends whether mpfrxx.h
from gmp-4.1.4 is usable with mpfr 2.2.0 (if yes, we can just %install it,
otherwise not sure what to do).

Comment 2 Eric Smith 2006-10-23 03:58:21 UTC
I'd like to join in the recomendation of removing mpfr from the gmp package, and
adding/creating a separate mpfr package based on the latest stable mpfr package
(2.2.0).  The mpfr site provides an SRPM that could serve as a basis for a
Fedora mpfr package.

The mpfr library bundled with gmp is very out of date, and has many bugs that
have been corrected in the upstream mpfr.  For instance, the old mpfr hangs when
attempting to compute two to a negative integer power, which I commonly need to do.


Comment 3 Jakub Jelinek 2006-10-23 11:29:13 UTC
I searched for users of mpfr within FC/FE.
FC:
gcc - only links libmpfr.a into f951

FE:
CGAL - only links libmpfr.a into *.so's, its use within installed headers
       is limited always within a single routine/method, i.e. no mpfr
       ABI part is passed around between .o files
genius - uses system libmpfr only if it is >= 2.2.0, otherwise
         falls back to its own copy of mpfr 2.2.0

None of these uses <mpfrxx.h> header.
From this I think it is safe to upgrade mpfr within gmp-4.1.4 src.rpm for
fc6/RHEL5 and do the split in fc7.


Comment 5 Laurent Rineau 2006-12-01 15:00:34 UTC
I am the packager of CGAL. Actually, I would like to package CGAL-python as 
well into Fedora Extras. That package dlopen 
libraries linked with libCGAL.so. So it requires a shared libmfpr.so. I have 
filled a new bug #218041 for that issue.

(In reply to comment #2)
> I'd like to join in the recomendation of removing mpfr from the gmp package,

+1 That would be a better solution.

> The mpfr library bundled with gmp is very out of date, and has many bugs 
that
> have been corrected in the upstream mpfr.  For instance, the old mpfr hangs 
when
> attempting to compute two to a negative integer power, which I commonly need 
to do.

The mpfr shipped with gmp is now mpfr-2.2.0, with the cumulative patch to 
2.2.0. It is not really old.


Comment 6 Laurent Rineau 2006-12-04 12:44:23 UTC
*** Bug 166450 has been marked as a duplicate of this bug. ***

Comment 7 Laurent Rineau 2006-12-04 12:45:17 UTC
*** Bug 199550 has been marked as a duplicate of this bug. ***

Comment 8 Ivana Varekova 2007-08-06 15:03:47 UTC
gmp is upgraded to gmp-4.2.1. mpfr is a separate package now (the current
version is mpfr-2.2.1 - with applied cumulative upstream patch). If there is any
problem I overlooked please open new bug. Thanks.


Note You need to log in before you can comment on or make changes to this bug.