Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 210 - rdist deletes remote subdirectory tree if local subdirectory has I/O error
Summary: rdist deletes remote subdirectory tree if local subdirectory has I/O error
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rdist
Version: 4.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-28 09:37 UTC by jve
Modified: 2015-03-05 01:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-03-22 22:45:36 UTC


Attachments (Terms of Use)

Description jve 1998-11-28 09:37:03 UTC
When rdist v6.1.0 can't read a local subdirectory due to an
I/O error, it emits a LOCAL ERROR message about the I/O
error, but then proceeds to delete the subdirectory and its
contents from the remote!  Sort of defeats the purpose of
using rdist to keep duplicates somewhere in case of a disk
failure, eh?

It should leave the remote subdirectory alone if it can't
read the local.

I have a log that I can provide if you need the 'proof', but
I didn't think it would paste well into this form.  :)

I checked the errata pages for RedHat 4.2-5.2 and didn't see
anything for rdist, so I assume this will apply to all
releases.

    John Van Essen <jve@gamers.org>

Comment 1 sharonw 2000-03-22 22:45:59 UTC
test

Comment 2 Jeff Johnson 2000-07-27 22:32:53 UTC
I have not a prayer of reproducing this problem. Please reopen with an explicit
test
case if you wish me to fix.


Note You need to log in before you can comment on or make changes to this bug.