Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 209939 - Anaconda terminates when incorrect web server/path entered
Summary: Anaconda terminates when incorrect web server/path entered
Keywords:
Status: CLOSED DUPLICATE of bug 208094
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2006-10-08 15:55 UTC by Andy Hudson
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-15 21:33:31 UTC


Attachments (Terms of Use)

Description Andy Hudson 2006-10-08 15:55:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1b2) Gecko/20060601 BonEcho/2.0b2 (Ubuntu-edgy)

Description of problem:
When trying to do an install via HTTP using the Fedora rescue CD I must have made a typo in my entry. Immediately after I entered the root password, I got an error message telling me that the installation information couldn't be found/repomd.xml etc. Anaconda then terminates and reboots the computer.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.Specify HTTP installation
2.Make a mistake in the server and path
3.Wait for Anaconda to try and find the package information

Actual Results:
Anaconda throws up an error message about package information not being available and restarts the computer.

Expected Results:
Anaconda should have been able to prompt me to let me know that what I had entered wasn't correct. It should then have allowed me to correct the information.

Additional info:
The 'expected results' is the behaviour in previous versions of Fedora Core. The check is normally done during the initial text mod, straight after the entry of the web server and path that is being used.

Comment 1 Jeremy Katz 2006-10-09 15:17:46 UTC
The problem is that we can't generically check given the variety of things that
can be specified in the second stage.

I've got some thoughts on resolving this post-FC6 by actually moving repository
specification into the second stage.

Comment 2 Andy Hudson 2006-10-09 17:13:44 UTC
If it helps I stuck to the defaults - I didn't change anything (including the
partitioning options).

All I did was choose my locale (London, Europe) and enter a root password. No
other options were changed.

Comment 3 David Cantrell 2007-03-15 21:33:31 UTC

*** This bug has been marked as a duplicate of 208094 ***


Note You need to log in before you can comment on or make changes to this bug.