Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 209537 - gdm should create a utmp entry for session
Summary: gdm should create a utmp entry for session
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
: 217198 (view as bug list)
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2006-10-05 21:18 UTC by jmccann
Modified: 2015-01-14 23:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-07 19:12:14 UTC


Attachments (Terms of Use)

Description jmccann 2006-10-05 21:18:32 UTC
Seems like it stopped doing this from:
http://cvs.fedora.redhat.com/viewcvs/devel/gdm/gdm-2.15.6-wtmp.patch?rev=1.2&view=auto

I think we really need a utmp entry.  We are going to be using this for some of
the ConsoleManager/PolicyKit/HAL stuff.

Is there a reason why this changed?

Thanks.

Comment 1 Ray Strode [halfline] 2006-10-05 21:46:58 UTC
yup, it's just a bug.  We should be creating a utmp entry for local logins, and
not for remote logins.

See http://bugzilla.gnome.org/show_bug.cgi?id=347871 for more details.

Note, I'm not sure it's a good idea to rely on utmp.  It's not really reliable.




Comment 2 David Zeuthen 2006-10-06 01:53:03 UTC
Well, for tracking user sessions we need something like this. And it's bigger
than Fedora, we'd want every OS that runs the growing Utopia stack (which soon
will include ConsoleManager and PolicyKit) to be able to track this.

Perhaps a better approach is to teach gdm, kdm and possibly login(1) about
talking to ConsoleManager. Each of these would call into ConsoleManager to
announce session add / remove. Would probably need some restructuring of how
things work, e.g. gdm, kdm and login(1) would need to babysit the session.

The latter is certainly a bit more robust.


Comment 3 Ray Strode [halfline] 2006-11-25 05:08:40 UTC
*** Bug 217198 has been marked as a duplicate of this bug. ***

Comment 4 Paul 2006-11-25 06:26:58 UTC
well i have lots of scripts that rely on 'finger' and 'w' and 'who', and none
are working.  should i add the SESSREG code back into /etc/gdm/PreSession and
PostSession?  What again is the downside of using sessreg again?

Comment 5 Paul 2006-11-25 09:20:58 UTC
So how exactly do you guys suggest that I finger my box in the meantime?

</set>

Comment 6 Ray Strode [halfline] 2006-11-27 00:24:39 UTC
Hi Paul,

Adding back the sessreg code (with just the -u argument and not the -w argument)
should work in the mean time.

The downside of the sessreg code is just that it doesn't support btmp logging
(It couldn't because it only gets run on successful logins).  Other than that,
it's fine, I think.

Comment 7 Matthew Miller 2007-04-06 16:08:08 UTC
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]


Comment 8 Tomas Mraz 2007-04-25 19:21:42 UTC
This bug breaks also pam_timestamp module.


Comment 9 Ray Strode [halfline] 2007-04-29 22:43:10 UTC
We should try to get some sort of fix for this in before fc7 final if I can.

Comment 10 Ray Strode [halfline] 2007-05-07 19:12:14 UTC
okay i added sessreg back on for utmp records.


Note You need to log in before you can comment on or make changes to this bug.