Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 208773 - yum traceback if /dev/log is not working
Summary: yum traceback if /dev/log is not working
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-10-01 21:06 UTC by Florian La Roche
Modified: 2014-01-21 22:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-24 22:01:24 UTC


Attachments (Terms of Use)

Description Florian La Roche 2006-10-01 21:06:17 UTC
Description of problem:

Recently a patch was added to yum to have it working even if
/dev/log exists, but is not working (kickstart installs and %post script).

Now yum does work in such a kickstart %post script, but tracebacks with
the following lines after doing a package install:

Error in atexit._run_exitfuncs:
Traceback (most recent call last):
  File "/usr/lib/python2.4/atexit.py", line 24, in _run_exitfuncs
    func(*targs, **kargs)
  File "/usr/lib/python2.4/logging/__init__.py", line 1333, in shutdown
    h.close()
  File "/usr/lib/python2.4/logging/handlers.py", line 642, in close
    if self.unixsocket:
AttributeError: SysLogHandler instance has no attribute 'unixsocket'


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jeremy Katz 2006-10-01 22:41:50 UTC
Hrm, this really looks like a python bug... 

Comment 2 Jeremy Katz 2006-10-13 01:23:22 UTC
Fixed in yum CVS, will be in the next build

Comment 3 Florian La Roche 2006-10-19 08:30:13 UTC
Still not working with current trees, did this get lost?

regards,

Florian La Roche


Comment 4 Jeremy Katz 2006-11-06 20:21:50 UTC
It should have been fixed in 3.0-6 afaik.  Was it not?

Comment 5 Florian La Roche 2006-11-06 20:52:32 UTC
Still happened with the -6 release.

regards,

Florian La Roche


Comment 6 Scott A. Friedman 2007-04-20 22:44:37 UTC
Bump - any update on this problem. Was/is it a python issue?

Comment 7 Jeremy Katz 2007-04-24 22:01:24 UTC
It was a python bug and the fix is included in python 2.5 for F7


Note You need to log in before you can comment on or make changes to this bug.