Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 208706 - work with transparent panels
Summary: work with transparent panels
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gaim
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-09-30 14:59 UTC by Matthias Clasen
Modified: 2007-11-30 22:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-10-23 18:24:53 UTC


Attachments (Terms of Use)
patch (deleted)
2006-09-30 14:59 UTC, Matthias Clasen
no flags Details | Diff

Description Matthias Clasen 2006-09-30 14:59:45 UTC
Here is a patch to make gaim work with transparent panels, by not forcing the
background of its tray icon to gray.

The patch updates the eggtrayicon copy to the latest upstream (which supports 
transparency), and makes the event box in the tray not have a visible window.

Comment 1 Matthias Clasen 2006-09-30 14:59:45 UTC
Created attachment 137476 [details]
patch

Comment 2 Matthias Clasen 2006-10-04 22:20:46 UTC
Warren, I put the patch in cvs, but gaim fails to build due to unrelated
errors. Can you take a look ?

Comment 3 Stu Tomlinson 2006-10-05 00:13:22 UTC
FYI, the equivalent of this patch (without the regressions for older GTK+
versions) is already in upstream SVN and will be in beta4

If I can be of any help with the "unrelated errors" let me know.

Comment 4 Warren Togami 2006-10-23 18:24:53 UTC
Fixed in FC6 and RHEL5.


Note You need to log in before you can comment on or make changes to this bug.