Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 208698 - "Software Updater" icon is not themeable
Summary: "Software Updater" icon is not themeable
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
: 229978 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-30 11:27 UTC by Joachim Frieben
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-11 19:05:54 UTC


Attachments (Terms of Use)

Description Joachim Frieben 2006-09-30 11:27:30 UTC
Description of problem:
As of "pirut-1.2.1-1", an "Echo" style icon is used for the menu entry
"Software Updater" although "Bluecurve" is chosen as active icon theme
on my system.

Version-Release number of selected component (if applicable):
pirut-1.2.1-1

How reproducible:
Always

Steps to Reproduce:
1. Log in to "GNOME" session.
2. Open "Applications" -> "System Tools".
  
Actual results:
The "Software Updater" icon is part of the "Echo" icon set although
"Bluecurve" is the active icon theme, and the "Echo" them does not
even exist as part of "Fedora".

Expected results:
The "Software Updater" icon is part of the "Bluecurve" icon set
because "Bluecurve" is the active icon theme.

Additional info:
» A corresponding entry is found in the "pirut" changelog:
   '* Fri Sep 29 2006 Jeremy Katz <katzj@redhat.com> - 1.2.1-1'
   '- remember to include the new pup icon'
» A suitable icon does already exist in the "Blucurve" icon set,
  namely: "icon-update.png".

Desktop file "pup.desktop" specifies "pup.png" as icon to be used for
the "Software Updater" entry. This does not comply with the "Fedora"
naming scheme and breaks themeability. The correct entry would be
"icon-update.png", and the "new" icon needs to carry the same name and
be part of a (future) "Echo" theme for the menu icon to be themeable.

Comment 1 Jeremy Katz 2007-02-26 14:26:06 UTC
*** Bug 229978 has been marked as a duplicate of this bug. ***

Comment 2 Joachim Frieben 2007-02-26 15:54:17 UTC
However, it already happened that a bug that I had committed was fixed
for the "devel" tree but remained unresolved in "FC6". Isn't this what
"cloning" a bug is meant for?

Comment 3 Joachim Frieben 2007-02-26 15:56:36 UTC
(In reply to comment #2)
> However, it already happened that a bug that I had committed was fixed
> for the "devel" tree but remained unresolved in "FC6". Isn't this what
> "cloning" a bug is meant for?

Read your comment from bug 229978 - apologies.

Comment 4 Jeremy Katz 2007-09-11 19:05:54 UTC
Will be following the icon theme in the next build


Note You need to log in before you can comment on or make changes to this bug.