Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 208580 - new Indic locale give unsupported locale wanring on Xlib apps
Summary: new Indic locale give unsupported locale wanring on Xlib apps
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libX11
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: Indic FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-09-29 14:23 UTC by Jens Petersen
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-30 22:47:44 UTC


Attachments (Terms of Use)
fixed patch from original one (deleted)
2006-09-29 17:34 UTC, Akira TAGOH
no flags Details | Diff

Description Jens Petersen 2006-09-29 14:23:31 UTC
Description of problem:
The new Indian locale that have been added (I guess) are giving Xlib
warnings at the startup of X apps.

Version-Release number of selected component (if applicable):
libX11-1.0.3-3.fc6

How reproducible:
every time

Steps to Reproduce:
1. run: LANG=or_IN.UTF-8 xterm
2. replace Oriya "or" by "as", "ml", "te", "ur", etc

Actual results:
Warning: locale not supported by Xlib, locale set to C

Expected results:
no warning

Additional info:
No warning appears for gtk/gnome apps.
Previous Indic locale ("hi", "gu", "bn", etc) and "mr" work fine.

Comment 1 Akira TAGOH 2006-09-29 17:34:44 UTC
Created attachment 137409 [details]
fixed patch from original one

I've tracked this down. this is caused by typo in locale.dir. so I updated the
patch that libX11 package contains. could you update the patch from attachment?

Comment 2 Akira TAGOH 2006-09-30 08:30:01 UTC
BTW this was actually fixed in upstream. but our patch seems to be old one. so
can someone quickly update the patch to fix this issue?

Comment 3 Matthias Clasen 2006-09-30 14:39:26 UTC
Can we get this in before the freeze ?

Comment 4 Søren Sandmann Pedersen 2006-09-30 22:47:44 UTC
Fixed in libX11-1.0.3-4.fc6 (releng pending).


Note You need to log in before you can comment on or make changes to this bug.