Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 208358 - Tar update broke rpmbuild -t
Summary: Tar update broke rpmbuild -t
Keywords:
Status: CLOSED DUPLICATE of bug 206841
Alias: None
Product: Fedora
Classification: Fedora
Component: tar
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-28 00:13 UTC by Adam Huffman
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-30 08:25:43 UTC


Attachments (Terms of Use)

Description Adam Huffman 2006-09-28 00:13:53 UTC
Description of problem:
I had been having trouble using rpmbuild to build RPMs from tarballs.
I tracked this down eventually to a change in behaviour in the new version of
tar.  Without setting TAR_OPTIONS to "--wildcards", the tarball is not extracted.

This change in behaviour should at least be documented.

Version-Release number of selected component (if applicable):
tar-1.15.91-1.FC5

How reproducible:
Every time

Steps to Reproduce:
1. rpmbuild -ta <tarball with .spec file inside)
2.
3.
  
Actual results:
rpmbuild fails because the tarball is not extracted

Expected results:
rpmbuild proceeds normally

Additional info:
The behaviour change is documented here:
http://www.gnu.org/software/tar/manual/html_node/Changes.html

Comment 1 Johan Kok 2006-09-30 08:25:43 UTC

*** This bug has been marked as a duplicate of 206841 ***


Note You need to log in before you can comment on or make changes to this bug.