Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 208008 - rpmbuild -ta (and variants) don't work
Summary: rpmbuild -ta (and variants) don't work
Keywords:
Status: CLOSED DUPLICATE of bug 206841
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-25 19:56 UTC by Laurie Reeves
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-25 21:05:51 UTC


Attachments (Terms of Use)

Description Laurie Reeves 2006-09-25 19:56:21 UTC
Description of problem:

rpmbuild -t seems broken. It gives error it would when it can't find the spec file. 

I have tried all the applicable variants of "-t" such as -ta, -tb, -ts.

Version-Release number of selected component (if applicable):

Current (Sept 25, 2006) Fedora Development rpm-build package: rpm-build-4.4.2-32

I have not tried any older rawhide versions.

How reproducible:

I have tried several different tarballs. Mostly my own creations that work fine
on Fedora 4 as well some 3rd party ones. I have not found one that works yet.

Steps to Reproduce:

Using system-config-keyboard as example only.

1. setup rpm build environment for user or use root
2. rpm -ivh
http://mirror.hiwaay.net/redhat/fedora/linux/core/development/source/SRPMS/system-config-keyboard-1.2.7-2.src.rpm
3. rpmbuild -ta system-config-keyboard-1.2.7.tar.bz2
  
Actual results:

error: Name field must be present in package: (main package)
error: Version field must be present in package: (main package)
error: Release field must be present in package: (main package)
error: Summary field must be present in package: (main package)
error: Group field must be present in package: (main package)
error: License field must be present in package: (main package)

Expected results:

Executing(%prep): /bin/sh -e /home/laurie/rpm/tmp/rpm-tmp.36136
+ umask 022
+ cd /home/laurie/rpm/BUILD
+ LANG=C
+ export LANG
+ unset DISPLAY
+ cd /home/laurie/rpm/BUILD
+ rm -rf system-config-keyboard-1.2.7
+ /usr/bin/bzip2 -dc /home/laurie/rpm/SOURCES/system-config-keyboard-1.2.7.tar.bz2
+ tar -xf -

[snip]

Additional info:

The man page is rather lite on details as to what the spec file should be
called, how deep it will search, which file it will choose if there are several,
etc.

I have searched bugzilla, the fedora-devel mailing list, and google and cannot
find any mention of this problem.

Comment 1 Michael Jennings (KainX) 2006-09-25 20:01:49 UTC
Doesn't anyone bother to search BEFORE reporting a bug?  This is about the
billionth duplicate of this same bug.

SEARCH BEFORE YOU FILE!


Comment 2 Laurie Reeves 2006-09-25 20:10:35 UTC
Sorry, I didn't mean to be a pest. I searched Fedora-Core/devel/rpm in bugzilla,
it gives 42 results, I read through every single one and found nothing similar.

Comment 3 Michael Jennings (KainX) 2006-09-25 20:13:14 UTC
Don't narrow it down like that.  A simple search for "rpmbuild -t" brings up
quite a collection of bugs.


Comment 4 Paul Nasrat 2006-09-25 21:05:51 UTC

*** This bug has been marked as a duplicate of 206841 ***


Note You need to log in before you can comment on or make changes to this bug.