Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 207571 - Fix the dictionary proliferation problem
Summary: Fix the dictionary proliferation problem
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Bill Nottingham
URL:
Whiteboard: bzcl34nup
: 127024 (view as bug list)
Depends On: 218762 218769 219777 245888
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2006-09-21 17:40 UTC by Bill Nottingham
Modified: 2014-03-17 03:02 UTC (History)
10 users (show)

Fixed In Version: F9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-04-15 11:53:05 UTC


Attachments (Terms of Use)

Description Bill Nottingham 2006-09-21 17:40:41 UTC
Right now, we have aspell-XX, openoffice.org dictionaries in the langpacks, and
vim-spell.

For FC7 we should go to a single shared dictionary source.

Comment 1 Caolan McNamara 2006-09-21 17:55:44 UTC
I posted about this last week on fedora-devel/fedora-desktop-devel. Actually
firefox/thunderbird/mozilla is also part of this as it is able to use myspell
dictionaries

ideally from my point of view

1. package hunspell standalone
2. make OOO use system hunspell (easyish)
3. package hunspell dictionaries seperately, perhaps some as extras dictionary
packages
4. upgrade firefox/mozilla from hunspell to myspell
5. tweak vim to not need to additionally convert these dictionaries (does it
curently do this?)

additionally more hand-wavingly...

6. replace aspell with hunspell (?)
6.1. make an aspell drop in replacement that backs onto hunspell (?)
6.2. tweak hunspell to be also able to use additional pure-aspell dictionaries
without modification, and accept lower quality spelling suggestions in this case (?)

Comment 2 Caolan McNamara 2006-09-21 17:57:13 UTC
ack!, 4. upgrade firefox/mozilla to hunspell from myspell

Comment 3 Andrew Overholt 2006-10-06 18:01:32 UTC
See also bug 209657.

Comment 4 Caolan McNamara 2006-11-09 12:26:36 UTC
See bug 214764 for splitting hunspell out from OOo, should do that anyway.

Comment 5 Caolan McNamara 2006-11-13 08:42:37 UTC
see https://bugzilla.mozilla.org/show_bug.cgi?id=319778 for a plausible patch to
upgrade firefox to use hunspell instead of myspell

Comment 6 Caolan McNamara 2006-11-30 12:37:39 UTC
1. package hunspell standalone (done)
2. make OOO use system hunspell (done)

3. package hunspell dictionaries separately, perhaps some as extras dictionary
packages
3.a) OOo can now as of 2.1.0-5.6 detect and use dictionaries that appear in
/usr/share/myspell automatically so anyone wanting to package extra dictionaries
for OOo can simply follow the pattern of
http://people.redhat.com/caolanm/hunspell/hunspell-af-0.20060117-1.src.rpm and
OOo will just see a LANG_REGION.dic in /usr/share/myspell as a dictionary for
LANG_REGION (i.e. not need for a DICT line in the obscure OOo dictionary.lst file)
3.b) and as an interim measure the current "built-in" OOo dictionaries have been
relocated into /usr/share/myspell

I'm a little unsure of what the extras/core/merge story is going to be, but the
obvious next step is to break them out of the OOo package and maintainership
into individual packages like the demo above. When there's a bit of clarity
there I'll either dump the lot of the dictionaries and leave it up to some
volunteers to add them to extras, or add them to extras/core/whatever is going
on myself

Comment 7 David Juran 2007-01-18 17:05:07 UTC
*** Bug 127024 has been marked as a duplicate of this bug. ***

Comment 8 John (J5) Palmieri 2007-02-01 16:39:40 UTC
what is the story with this?  We want this for OLPC as aspell is being brought
in by enchant (which is brought in by abiword).  Aspell brings in perl which we
absolutly do not want.  With hunspell (provided firefox is ported to it) we
would have a single dictionary for all of our apps.

Comment 9 Caolan McNamara 2007-02-01 16:51:16 UTC
well hunspell is in fedora, as in hunspell-en. The rest of the hunspell
dictionaries are ready to be set for review for inclusion into fedora post the
extras/core merge. 

So really sounds like that for your needs you should investigate configuring
enchant to use hunspell as the backend, either exclusive of aspell in an olpc
branch, or tweak the generic enchant to dlopen aspell and hunspell and not
dependancy requre aspell so that the requirement of aspell becomes optional.

Comment 10 Bug Zapper 2008-04-03 18:17:08 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 11 David Juran 2008-04-15 11:53:05 UTC
According to http://fedoraproject.org/wiki/Releases/FeatureDictionary, this is
now done in rawhide so I'm closing this issue.


Note You need to log in before you can comment on or make changes to this bug.