Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 207458 - system-config-date for pa_PK shows multiple languages in UI
Summary: system-config-date for pa_PK shows multiple languages in UI
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk2
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2006-09-21 07:52 UTC by Mayank Jain
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-26 12:47:19 UTC


Attachments (Terms of Use)
multiple languages in UI (deleted)
2006-09-21 07:52 UTC, Mayank Jain
no flags Details

Description Mayank Jain 2006-09-21 07:52:57 UTC
Description of problem:
System-config-date for pa_PK shows multiple languages in UI - See the attached
screenshot. The UI should be showing any one language consistantly.


Version-Release number of selected component (if applicable):
glibc-common-2.4.90-33
glibc-2.4.90-33

How reproducible:
Everytime

Steps to Reproduce:
1. open gnome-terminal
2. LANG=pa_PK system-config-date
3. Observe the UI with two different languages
  
Actual results:
Any one language should be shown onsistantly across the UI - as in case of gedit

Expected results:
Mix of two languages shown - see screenshot

Additional info:
None

Comment 1 Mayank Jain 2006-09-21 07:52:59 UTC
Created attachment 136830 [details]
multiple languages in UI

Comment 2 Ulrich Drepper 2006-09-21 16:53:02 UTC
And what do you expect?  None of the maintainers have any clue about any of
these languages.  Either you can come up with a patch or we'll close it.

Comment 3 Mayank Jain 2006-09-22 03:39:11 UTC
Hi Ulrich,

As per the Language maintainers, the language in which week names are appearing
is the correct language for pa_PK (ShahMukhi/Urdu). However, the translations
the UI is picking are from pa_IN (Punjabi), which is totally incorrect.

If the applications have no pa_PK translations, the text in UI should be
displayed in simple english (or fall back locale translations).

Hence, IMHO, this is a bug which somehow relates to misunderstanding and mixing
of pa_IN & pa_PK locales.

Thanks,
Mayank

Comment 4 Ulrich Drepper 2006-09-22 06:02:33 UTC
Then this is a problem with the naming of the translation files.  Probably one
is named pa.po (with binary pa.mo) which is on the search path in case pa_PK.po
or pa_IN.po does exist.  Rename the file.  This is no glibc problem.

Comment 5 Nils Philippsen 2006-09-22 09:22:56 UTC
The widget in question is a stock Gtk widget, so its translations are bound to
be made there as well. Changing component to gtk2.

Comment 6 Matthias Clasen 2006-09-23 21:57:37 UTC
Mayank, GTK+ has only a pa.po file, which is for Punjabi. I assume other Gnome
projects are in a similar situation. (a quick check for nautilus, gnome-panel and
evince confirms this). 

So, in order to improve this situation, you need
a) a translation team for pa_PK
b) a mail to gnome-i18n@gnome.org to discuss the issue
   of renaming pa to pa_IN throughout Gnome

Both of this is clearly not doable in the FC6 timeframe


Comment 8 Mayank Jain 2006-09-25 07:55:57 UTC
Hi,

I just did a small test...

I downloaded Gedit, copied $gedit/po/pa.po to $gedit/po/pa_PK.po & compiled &
installed it. As i found, $prefix/share/locale/pa_PK/LC_MESSAGES gets formed.

Hence, it seems as if pa_PK has glibc support but clearly Gnome seems to be
messing it up.

Am I right in this finding... Matthias?

BTW, Ankit, thanks for the help.

Comment 9 Matthias Clasen 2006-10-16 20:03:30 UTC
Sounds right.

Comment 10 Matthias Clasen 2007-02-26 12:47:19 UTC
Whatever you want to happen here needs to happen upstream in gnome.


Note You need to log in before you can comment on or make changes to this bug.