Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 207348 - setroubleshootd fails with multiple errors but service start reports [ OK ]
Summary: setroubleshootd fails with multiple errors but service start reports [ OK ]
Keywords:
Status: CLOSED DUPLICATE of bug 207453
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-09-20 19:34 UTC by Dave Malcolm
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-29 21:17:10 UTC


Attachments (Terms of Use)

Description Dave Malcolm 2006-09-20 19:34:10 UTC
Description of problem:
[david@brick sbin]$ sudo /sbin/service setroubleshoot start
Starting setroubleshootd:                                  [  OK  ]

However, /var/log/setroubleshoot/setroubleshootd.log shows multiple
serious-looking errors:
(a) one of these for each plugin:
2006-09-20 15:29:26,330 [plugin.ERROR] failed to load httpd_enable_homedirs plugin
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/setroubleshoot/util.py", line 312, in
load_plugins
    mod = imp.load_module(module_name, *imp.find_module(plugin_name, [plugin_dir]))
  File "/usr/share/setroubleshoot/plugins/httpd_enable_homedirs.py", line 20, in ?
    from setroubleshoot.Plugin import Plugin
  File "/usr/lib/python2.4/site-packages/setroubleshoot/Plugin.py", line 123
    rpm = get_rpm_nvr_by_file_path(self.path.strip('"')))
                                                        ^
SyntaxError: invalid syntax
(repeats for every plugin, predictably)

(b) 2006-09-20 15:29:27,933 [avc.WARNING] audit socket (/var/run/audit_events)
failed, error='No such file or directory', retry in 60 seconds
which does indeed repeat and fills up the log.

No troubleshoot popups appear and package is broken :-(

Do you want me to break out these two separate problems into different bug
reports?  The third problem (c.f. Summary) is that I was unaware of this
breakage and thought that the service was running and was merely failing to
generate AVCs :-(

Version-Release number of selected component (if applicable):
setroubleshoot-0.42-2

How reproducible:
100%

Comment 1 John Dennis 2006-09-29 21:17:10 UTC

*** This bug has been marked as a duplicate of 207453 ***


Note You need to log in before you can comment on or make changes to this bug.