Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 207239 - rpmbuild -ta broken by recent tar
Summary: rpmbuild -ta broken by recent tar
Keywords:
Status: CLOSED DUPLICATE of bug 206841
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-20 05:19 UTC by Mike Pope
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-20 07:27:07 UTC


Attachments (Terms of Use)
Annotated strace output (deleted)
2006-09-20 05:19 UTC, Mike Pope
no flags Details

Description Mike Pope 2006-09-20 05:19:05 UTC
Description of problem:
rpmbuild -ta has stopped working, since tar-1.15.91.1.FC5.  Downgrading to 
tar-1.15.90-2.FC5 fixes the problem.  The more recent tar whines about 
rpmbuild execing it with the *.spec argument, and the message confuses 
rpmbuild.  See the attached summarized strace output.

Version-Release number of selected component (if applicable):
rpm-build-4.4.2.15.2 (meta-buglet: bugzilla does not list rpm-build in the 
Component menu)

How reproducible:
rpmbuild -ta <known-working-tarball>

Actual results:
error: Name field must be present in package: (main package)
...etc,etc

Expected results:
.rpm built as usual.

Additional info:

Comment 1 Mike Pope 2006-09-20 05:19:05 UTC
Created attachment 136704 [details]
Annotated strace output

Comment 2 Nalin Dahyabhai 2006-09-20 05:28:19 UTC
Looks like a duplicate of bug #206841.

Comment 3 Paul Nasrat 2006-09-20 07:27:07 UTC
Workaround for now is TAR_OPTIONS=--wildcards discussion is occuring on
rpm-devel list about the correct way to fix.

*** This bug has been marked as a duplicate of 206841 ***


Note You need to log in before you can comment on or make changes to this bug.