Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 206763 - empty cupsd.conf file
Summary: empty cupsd.conf file
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
: 206892 (view as bug list)
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-09-16 10:50 UTC by Tim Waugh
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 1.2.4-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-29 14:04:44 UTC


Attachments (Terms of Use)

Description Tim Waugh 2006-09-16 10:50:06 UTC
Description of problem:
When adjusting server settings using the http://localhost:631/ interface,
/etc/cups/cupsd.conf ends up zero-length.

Version-Release number of selected component (if applicable):
cups-1.2.3-3

How reproducible:
100%

Steps to Reproduce:
1. Fresh install or 'cp /etc/cups/cupsd.conf{.default,}; /sbin/service cups restart'
2. Go to http://localhost:631/ in firefox
3. Manage server
4. Publish shared printers

Actual results:
Connection refused after server is told to restart

Expected results:
Normal operation.

Comment 1 Tim Waugh 2006-09-16 10:53:57 UTC
Upstream bug report:
  http://cups.org/str.php?L1976


Comment 2 Tim Waugh 2006-09-18 10:24:58 UTC
*** Bug 206892 has been marked as a duplicate of this bug. ***

Comment 3 Tim Waugh 2006-09-29 14:04:44 UTC
This was fixed in 1.2.4-2.


Note You need to log in before you can comment on or make changes to this bug.