Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 206500 - Better error-reporting for failure in desktop-effects dialog
Summary: Better error-reporting for failure in desktop-effects dialog
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Søren Sandmann Pedersen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-09-14 18:49 UTC by Dave Malcolm
Modified: 2014-06-18 09:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-19 17:38:05 UTC


Attachments (Terms of Use)

Description Dave Malcolm 2006-09-14 18:49:38 UTC
Version-Release number of selected component (if applicable):
compiz-0.0.13-0.23.20060817git.fc6

How reproducible:
100% on this machine

Steps to Reproduce:
1. run from the panel (Desktop->Preferences->More Preferences->Desktop Effects) 
2. click on Enable Desktop Effects button

  
Actual results:
Chaos on screen for about 10 seconds, after which the display is restored, with
the button sensitized.  A few seconds later, chaos begins again, some seconds
later the button is back to how it was before.

There's no visible output that an error occurred.

If I run desktop-effects from a terminal, the following is logged to the terminal:
GTK Accessibility Module initialized
string: metacity
attempting to run compiz
GTK Accessibility Module initialized
gnome-window-decorator: Screen 0 on display ":0.0" already has a decoration
manager; try using the --replace option to replace the current decoration manager.
compiz: No GLXFBConfig for default depth, this isn't going to work.
compiz: Failed to manage screen: 0
compiz: No managable screens found on display :0.0
GTK Accessibility Module initialized

Expected results:
Would hope that an error dialog of some kind would have popped up saying that it
didn't work, possibly containing the textual output from above, or at least
recommending that I run things from a terminal to gather further information.

Comment 1 Søren Sandmann Pedersen 2006-09-14 21:30:29 UTC
fc6 target

*** This bug has been marked as a duplicate of 150223 ***

Comment 2 Søren Sandmann Pedersen 2006-09-15 19:51:00 UTC
CVS should now report an error when compiz doesn't start correctly. I haven't
built a new package yet, so I'm leaving this bug open.

Comment 3 Søren Sandmann Pedersen 2006-09-19 17:38:05 UTC
Fixed, provided releng moves the package


Note You need to log in before you can comment on or make changes to this bug.