Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 206397 - Underline isn't rendered at the proper place
Summary: Underline isn't rendered at the proper place
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: scim
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target 208921 220282
TreeView+ depends on / blocked
 
Reported: 2006-09-14 04:32 UTC by Jong Bae KO
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-12-15 07:47:01 UTC


Attachments (Terms of Use)
Typing hangul with scim-hangul, Preedit with Underline on gedit. (deleted)
2006-09-15 11:46 UTC, sangu
no flags Details
preedit of scim-hangul on openoffice writer (deleted)
2006-09-19 06:08 UTC, sangu
no flags Details

Description Jong Bae KO 2006-09-14 04:32:22 UTC
Description of problem:
When you type the Hangul, the underline is appeared on the char, but It isn't
apeared the bottom of the letter. It is 5~10% upper than where I expect apearing
underline in firefox and gedit.

In my opinion, Underline is useless, becuase Hangul is one letter, and
Windows(ime2002) doesn't have underline.
I might discuss with Korean users or djoo about it.


Version-Release number of selected component (if applicable):
scim-hangul-0.2.2-7.fc6

How reproducible:
always

Steps to Reproduce:
1. run gedit and increase the font size
2. activate the scim-hangul
3. type"rnr" <--"극"
  
Actual results:


Expected results:


Additional info:

Comment 1 Akira TAGOH 2006-09-14 05:51:36 UTC
Well, appearing the underline isn't a bug since scim-hangul uses the preedit.
however rendering it at a character 5~10% upper looks like a Pango or freetype
bug, or font perhaps. reassigning to pango for now.

Comment 2 Behdad Esfahbod 2006-09-14 15:36:05 UTC
Attach screenshots please if you can.  And which font is it?  I probably can
reproduce using the font only.

Comment 3 Jong Bae KO 2006-09-15 00:10:26 UTC
Sorry I can't make screenshots because of pre-editing state.
It is default korean font(Baekmuk), and it is included on FC and RHEL as well

Comment 4 sangu 2006-09-15 11:46:27 UTC
Created attachment 136345 [details]
Typing hangul with scim-hangul, Preedit with Underline on gedit.

This problem doesn't happen in nabi or imhangul.
nabi and imhangul are hangul input method.

Comment 5 sangu 2006-09-19 06:08:20 UTC
Created attachment 136604 [details]
preedit of scim-hangul on openoffice writer

The same problem happens on openoffice writer.
So this problem isn't pango bug and scim bug.

Comment 6 sangu 2006-09-19 06:16:53 UTC
So this problem isn't pango bug but scim bug, maybe.

Comment 7 sangu 2006-09-19 06:54:54 UTC
Patch (Default underline preedit attributes is not appropriate) : 
http://sourceforge.net/mailarchive/forum.php?thread_id=30576356&forum_id=43684

Comment 8 Jong Bae KO 2006-09-20 02:30:12 UTC
The Main problem is SCIM, becuase Hangul doesn't need a underline.
I discussed with sangu and krisna. krisna said that GTK2 and XIM is using
Underline from SCIM, and he said Hangul doesn't need it.

However, Underline should be fixed in Pango as well.

Comment 9 sangu 2006-09-20 03:00:08 UTC
See Also : another underline problem in pango - bug 204016

Comment 10 Jens Petersen 2006-09-29 16:03:41 UTC
A patch related to this for gtkimm has been committed upstream:

[Scim-cvs] scim/extras/gtk2_immodule gtkimcontextscim.cpp, 1.170.2.7,	1.170.2.8


Comment 11 Jens Petersen 2006-10-02 16:57:40 UTC
This should be fixed now for the scim gtkimm and xim in scim-1.4.4-35.fc6
with patches from upstream cvs.  Will open another bug for scim-bridge.

Comment 12 Ryo Dairiki 2006-10-07 11:56:33 UTC
It must be fixed on the cvs latest.
Please try it and tell me if there's a problem. :)

Comment 13 Jong Bae KO 2006-10-13 06:10:11 UTC
Hi Jens
It is fixed in gedit. what about in firefox? I can still see underline.

scim-1.4.4-35.fc6


Comment 14 Jens Petersen 2006-10-16 08:40:36 UTC
scim-bridge bug is bug 208921.

Comment 15 Jong Bae KO 2006-10-31 03:22:21 UTC
This bug is appeared on nautilus in RHEL5(rawhide-2006.10.27).

nautilus-2.16.0-7.el5


Comment 16 Jens Petersen 2006-11-01 05:11:36 UTC
(In reply to comment #15)
> This bug is appeared on nautilus in RHEL5(rawhide-2006.10.27).
> nautilus-2.16.0-7.el5

Can you explain?

Comment 17 Jong Bae KO 2006-11-02 00:55:44 UTC
Hi Jens

Steps to Reproduce:
1. run nautilus and make new folder
2. activate the scim-hangul
3. type"rmrrmr" <--"극극"

It will show underline over the letters.

PS. When you enter key or click mounse, Last letter doesn't included in folder
name. bug 207026

 



Comment 18 Jens Petersen 2006-11-02 01:26:11 UTC
(In reply to comment #17)
> It will show underline over the letters.

I think you need to be running scim-bridge-0.4.5-4 or later

> PS. When you enter key or click mounse, Last letter doesn't included in folder
> name. bug 207026

207026 seems to be a different bug.

Comment 19 Jong Bae KO 2006-11-02 01:40:25 UTC
It is fixed in scim-bridge-0.4.5-4.el5
Thanks Jens

207026 is a different bug.

Comment 20 Jong Bae KO 2006-11-02 01:44:49 UTC
sorry I wrote wrong bug number
It is bug 207062


Note You need to log in before you can comment on or make changes to this bug.