Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 206320 - X apps don't work after sudo
Summary: X apps don't work after sudo
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: sudo
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-09-13 17:15 UTC by Jeremy Katz
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-22 13:00:46 UTC


Attachments (Terms of Use)

Description Jeremy Katz 2006-09-13 17:15:31 UTC
With the changed xauth bits in FC6, trying to read ~/.Xauthority and "assuming"
that works as sudo has done in the past doesn't continue to work.

Comment 1 Tomas Mraz 2006-09-18 13:11:10 UTC
Does it mean that sudo su - and running X app from the shell doesn't work? This
probably never worked right.

Or that direct sudo Xapp doesn't work?

Comment 2 Karel Zak 2006-09-18 13:19:45 UTC
I think "sudo xapp" has never worked. See
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=164671#c4

Comment 3 Jeremy Katz 2006-09-18 17:09:22 UTC
It worked fine in FC5 (as long as you're sudo'ing on the local machine) as the
xauth cookie was readable and things worked.  Now that we do xauth based on user
(to avoid hostname changes breaking things), it's broken

Comment 4 Tomas Mraz 2006-09-20 14:43:32 UTC
Default sudoers file must be modified to contain 'XAUTHORITY' in the 'Defaults
env_keep' settings.

Problem solved.


Comment 5 Peter Vrabec 2006-09-21 08:52:46 UTC
thnx. Tomas, it's fixed in sudo-1.6.8p12-9


Comment 6 Peter Vrabec 2006-09-22 13:00:46 UTC
latest-pkg  dist-fc6 sudo
sudo-1.6.8p12-9 dist-fc6 pvrabec



Note You need to log in before you can comment on or make changes to this bug.