Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 206125 - scim-chewing: Trigger keys setting isn't correct
Summary: scim-chewing: Trigger keys setting isn't correct
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: scim-chewing
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caius Chance
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-09-12 09:34 UTC by Xiaohong Wang
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-29 05:54:21 UTC


Attachments (Terms of Use)
proposed patch (deleted)
2006-09-15 07:14 UTC, Caius Chance
no flags Details | Diff

Description Xiaohong Wang 2006-09-12 09:34:26 UTC
Description of problem:


Version-Release number of selected component (if applicable):
scim-chewing-0.3.1-4.fc6

How reproducible:
always

Steps to Reproduce:
1.activate scim-chewing, ctrl-SPACE
2.right-click on the SCIM icon, on the prompted window, click SCIM Setup
3.click Chewing in the left pane
4.in the Keyboard tabbed section, click button after "Trigger keys: Ctrl+space"
5.check key setting in Select trigger keys window
  
Actual results:
In Select trigger keys window, it displays that Trigger key is space, but in the
Keyboard tabbed section, it displays that Trigger key is Ctrl+space

Don't do any change in select trigger keys window, just click OK button on it.
Then the Trigger key change to be space. (since nothing changed, it shouldn't
turn from Ctrl+space to space)

Expected results:


Additional info:

Comment 1 Caius Chance 2006-09-15 05:43:03 UTC
It seems to be the GUI doesn't reflect the value accurately.

When you delete the problem key and add "Control+Space" key manually, it is not
reproduceable as above.

Looking into it.

-----

BTW, the trigger key doesn't perform nothing when I press that in gedit with
chewing on as my observation.

Comment 2 Caius Chance 2006-09-15 07:14:22 UTC
Created attachment 136335 [details]
proposed patch

As 'Ctrl+space' is not a valid key combination, 'Ctrl' was omitted when
configuration page loads.

It should be 'Control+space'.

Comment 3 Caius Chance 2006-09-15 07:30:25 UTC
Patched & rebuilt.

Reported to upstream:
http://rt.openfoundry.org/Foundry/Project/Tracker/Display.html?Queue=263&id=23574

Please reopen this bug if found problem still exists.

Comment 4 Xiaohong Wang 2006-09-29 05:55:29 UTC
Verified that it has been fixed in latest FC6:
# rpm -q scim-chewing
scim-chewing-0.3.1-6.fc6


Note You need to log in before you can comment on or make changes to this bug.