Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 206112 - scim-chewing: Esc key to clean all buffer couldn't be disabled
Summary: scim-chewing: Esc key to clean all buffer couldn't be disabled
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: scim-chewing
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caius Chance
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-09-12 07:24 UTC by Xiaohong Wang
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: scim-chewing-0.3.1-9.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-12 07:13:08 UTC


Attachments (Terms of Use)
proposed patch (deleted)
2006-09-18 23:49 UTC, Caius Chance
no flags Details | Diff

Description Xiaohong Wang 2006-09-12 07:24:17 UTC
Description of problem:


Version-Release number of selected component (if applicable):
scim-chewing-0.3.1-4.fc6

How reproducible:
always

Steps to Reproduce:
1.activate scim-chewing, ctrl-SPACE
2.right-click on the SCIM icon, on the prompted window, click SCIM Setup
3.click Chewing in the left pane
4.in the Options tabbed section, uncheck "Esc key to clean all buffer" 
5.click OK and enter ji3 in gedit
6.press Esc key
  
Actual results:
buffer is cleaned

Expected results:
Since "Esc key to clean all buffer" is unchecked, press Esc key shouldn't clear
buffer

Additional info:

Comment 1 Caius Chance 2006-09-15 04:07:25 UTC
Please confirm if the setting of "Esc Key to clean all buffer" was updated after
user has pressed OK key?

On my test machine, the checkbox of "Esc key to clean all buffer" is always
reverted to unchecked after pressing OK key.

Comment 2 Caius Chance 2006-09-18 06:34:19 UTC
After observation, setting of "Esc key to clean all buffer" which is reflected
by key "/IMEngine/Chewing/EscCleanAllBuffer" has not been updated.

After OK key has been clicked with checkbox of such setting is ticked, that
setting has not been saved to ~/.scim/config.

Comparing to settings on same tab: "Add Phrase forward" and "SpaceKey as
selection key", they are perfectly be saved but "Esc key to clean all buffer" isn't.

Comment 3 Caius Chance 2006-09-18 23:49:20 UTC
Created attachment 136593 [details]
proposed patch

Please make sure patchee is version 0.3.1-5.

Package is being rebuilt and being tested by QA.

Comment 4 Ramakrishna Reddy Yekulla 2007-01-12 07:13:08 UTC
Package version Number ::
scim-chewing-0.3.1-9.fc7.x86_64

Steps to reproduce::
1. Activate scim [short keys :: Ctrl + Space ]
2. scim -> chinese (Traditional) -> chewing
3. Right click on the scim widget below
4. SCIM Setup
5. choose Chewing 
6. In Option check/select the field "Esc key to clean all buffer"
7. Apply -> Ok  
8. gedit -> type the following key sequence ji3 (我)
9. "Esc" :: ( should clear the buffer text)
10. scim -> chinese (Traditional) -> chewing
11. Right click on the scim widget below
12. SCIM Setup
13. choose Chewing 
14. In Option uncheck/deselect the field "Esc key to clean all buffer
15. Apply -> Ok  
16. gedit -> type the following key sequence ji3 (我)
17. "Esc" :: ( should not clear the buffer text, since its disabled)


Observation
Both the "Esc" functions of enableing and disabling  key to clean all buffer for
this release, hence resolving bug for this version.


Note You need to log in before you can comment on or make changes to this bug.