Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2061 - DHCP will not work with token ring cards
Summary: DHCP will not work with token ring cards
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dhcpcd
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard:
: 3175 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-08 16:30 UTC by martin
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-02 11:16:48 UTC


Attachments (Terms of Use)

Description martin 1999-04-08 16:30:01 UTC
DHCP reports "Not an Ethernet device" for Token Ring Cards

The following patch fixes it:

--- dhcpcd-0.65/if.c	Thu May  8 04:36:49 1997
+++ dhcpcd-0.65.new/if.c	Thu Apr  8 16:45:29 1999\
@@ -72,8 +72,9 @@
 	if ( ioctl(s, SIOCGIFHWADDR, &ifr) < 0 ) {
 		logSysExit("ioctl SIOCGIFHWADDR\
(ifConfig)");
 	}
-	if ( ifr.ifr_hwaddr.sa_family != ARPHRD_ETHER ) {
-		logQuit("ifInit: interface %s is not\
Ethernet\n", ifr.ifr_name);
+	if ( ifr.ifr_hwaddr.sa_family != ARPHRD_ETHER
+	&&   ifr.ifr_hwaddr.sa_family != ARPHRD_IEEE802) {
+		logQuit("ifInit: interface %s is not a\
valid interface\n", ifr.ifr_name);
 	}
 	/* save hardware address of the interface
 	 */

Comment 1 David Lawrence 1999-04-08 17:01:59 UTC
We do not currently have a token ring network to verify this problem
on. We are hoping to set one up in the near future. I am passing this
on to a developer for further review.

Comment 2 Jeff Johnson 1999-06-02 11:03:59 UTC
*** Bug 3175 has been marked as a duplicate of this bug. ***

dhcpcd requires a patch to work with TokenRing.

I have submitted the patch under this bug id.

------- Additional Comments From dkl@redhat.com  06/01/99 17:17 -------
Please send the patch again. It didnt seem to make it into the system
properly. For the proper way to do this refer to
http://developer.redhat.com/bugzilla/redhat-faq.phtml#howdoipatch

Thanx

Comment 3 Jeff Johnson 1999-06-02 11:16:59 UTC
Fixed (by applying similar patch) in dhcpcd-1.3.17pl5-2. Thanks for
the patch.


Note You need to log in before you can comment on or make changes to this bug.