Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 205705 - cups-1.2.3-1.2 broke printing system on fc5
Summary: cups-1.2.3-1.2 broke printing system on fc5
Keywords:
Status: CLOSED DUPLICATE of bug 205619
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-09-08 01:21 UTC by ron banks
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-11 09:27:17 UTC


Attachments (Terms of Use)
Cups error log text during upgrade and downgrade (deleted)
2006-09-08 13:37 UTC, ron banks
no flags Details
Cups ErrorLog Debug2 (deleted)
2006-09-08 15:26 UTC, ron banks
no flags Details

Description ron banks 2006-09-08 01:21:41 UTC
Description of problem:
After a yum update for cups many applications showed only the generic printer or
would just hang when File|Print was clicked. Twice after the upgrade the
computer just froze and had to be reset. Running rpm --oldpackage on cups and
cups-lib corrected the problem.

Version-Release number of selected component (if applicable):
cups-1.2.3-1.2.i386.rpm
cups-libs-1.2.3-1.2

How reproducible:
Rebooted several times but results were constant.

Steps to Reproduce:
1. Ran yum -y update and had cups and cups-libs updated
2. Failed to print from Adobe Reader 7.0 or any OOo 2.0 application.
3. Downloaded previous versions and then rpm --oldpackage cups* cups-lib and all
was well again.
  
Actual results:
Printing system crashed and burned

Expected results:
Printing system would be upgraded to a higher plane of existence and usefullness.

Additional info: That's about it.

Comment 1 Tim Waugh 2006-09-08 08:39:25 UTC
I haven't seen this at all here.

Please show me the output of 'lpstat -t' after the update.  Thanks.

Comment 2 ron banks 2006-09-08 11:18:50 UTC
Tim, I searched prior to filing this report. I didn't see anything else either.
This is the output before the upgrade:
[root@156 ~]# lpstat -t
scheduler is running
system default destination: LinuxLexmark
device for Cups-PDF: cups-pdf:/
device for LinuxLexmark: parallel:/dev/lp0
device for LinuxPhaser560: socket://10.0.0.254:9100
device for LinuxPhaser780: ipp://10.0.0.253/printers/queue1
Cups-PDF accepting requests since Fri 01 Sep 2006 02:35:46 PM EDT
LinuxLexmark accepting requests since Fri 01 Sep 2006 09:29:25 PM EDT
LinuxPhaser560 accepting requests since Fri 01 Sep 2006 09:42:41 PM EDT
LinuxPhaser780 accepting requests since Fri 01 Sep 2006 06:19:43 AM EDT
printer Cups-PDF is idle.  enabled since Fri 01 Sep 2006 02:35:46 PM EDT
printer LinuxLexmark is idle.  enabled since Fri 01 Sep 2006 09:29:25 PM EDT
printer LinuxPhaser560 is idle.  enabled since Fri 01 Sep 2006 09:42:41 PM EDT
printer LinuxPhaser780 is idle.  enabled since Fri 01 Sep 2006 06:19:43 AM EDT

After the upgrade 'lpstat -t' does not return at all. Just a flashing cursor. I
have not done any further testing since downgrading got me going again. As I
stated in the original report the system does seem slower which would be
expected if programs running can't handle not detecting a printing sub-system
very well. On a couple of occasions the computer just froze and had to be reset.

Comment 3 Tim Waugh 2006-09-08 12:42:31 UTC
Could you attach /var/log/cups/error_log please?

Comment 4 ron banks 2006-09-08 13:37:18 UTC
Created attachment 135846 [details]
Cups error log text during upgrade and downgrade

Cups error log text during upgrade and downgrade

Comment 5 Tim Waugh 2006-09-08 14:17:58 UTC
Okay, I don't see anything in there that gives us any clue about what's going
on, so I'll need to enable more debugging output.

Please stop CUPS, as root:

  /sbin/service cups stop

Then clear out the error_log file:

  >/var/log/cups/error_log

Edit the /etc/cups/cupsd.conf file so that the LogLevel line reads:

LogLevel debug2

Then start CUPS again:

  /sbin/service cups start

Now, run 'lpstat -t' again, wait a while, and then attach
/var/log/cups/error_log here.

Comment 6 ron banks 2006-09-08 15:26:20 UTC
Created attachment 135854 [details]
Cups ErrorLog Debug2

Cups ErrorLog Debug2

Comment 7 Tim Waugh 2006-09-08 17:26:13 UTC
Thanks.  Investigating.

Comment 8 Hermon Schools 2006-09-08 19:59:12 UTC
Running rpm --oldpackage on cups and
> cups-lib corrected the problem.

Hi,

We're having the same problem here. Except I can't even run the oldpackages
command. Here is my output:

[root@hhs3 Install additional software]# rpm --oldpackage cups-*
rpm: only installation, upgrading, rmsource and rmspec may be forced

Comment 9 ron banks 2006-09-08 20:58:13 UTC
You did download the older versions of the cups-1.2.2-1.8.i386.rpm and
cups-libs-1.2.2-1.8.i386.rpm and cd to where you saved them at before running
the rpm command first, didn't you. Once you are in the directory where you have
saved those 2 files to you run this command to downgrade the packages:

rpm -Uvh --oldpackage cups*.rpm

The rpm error was telling you that you have to use an installation command -Uvh
with the --oldpackage option.

REB

Comment 10 Fred New 2006-09-09 16:49:10 UTC
I experienced the same problem, so I followed the debug2 instructions above and
created a 251 MB error_log.  It is 39 MB before I get to a huge monotony of

d [09/Sep/2006:18:53:00 +0300] cupsdReadClient: 6, used=0, file=-1 state=7
d [09/Sep/2006:18:53:00 +0300] cupsdReadClient: 6, used=0, file=-1 state=7
d [09/Sep/2006:18:53:00 +0300] cupsdReadClient: 6, used=0, file=-1 state=7
d [09/Sep/2006:18:53:00 +0300] cupsdReadClient: 6, used=0, file=-1 state=7

My 251 MB error_log ends with messages from stopping cups again.  If someone
wants to see any of this, please tell me which part you want (or if I should
gzip it).

With the previous version of cups and cups-libs, lpstat shows the following:
$ lpstat -t
scheduler is running
system default destination: LJ4L
device for LJ4L: hp:/par/LaserJet_4L?device=/dev/parport0
LJ4L accepting requests since Sat 09 Sep 2006 07:00:02 PM EEST
printer LJ4L is idle.  enabled since Sat 09 Sep 2006 07:00:02 PM EEST

Comment 11 Tim Waugh 2006-09-11 09:27:17 UTC
Okay, this looks the same as bug #205619.  I'll mark this as a duplicate.

*** This bug has been marked as a duplicate of 205619 ***


Note You need to log in before you can comment on or make changes to this bug.