Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 204547 - epiphany doesn't pick up gnash plugin
Summary: epiphany doesn't pick up gnash plugin
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: epiphany
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
: 165520 228480 232384 232385 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-29 20:44 UTC by David Nielsen
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-16 16:07:29 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 407419 None None None Never

Description David Nielsen 2006-08-29 20:44:06 UTC
Description of problem:
When installing gnash-plugin it registers fine with firefox but not with
epiphany which strikes me as odd since they use the same backend.
Copying the plugin .so file into every firefox/mozilla plugins directory makes
it pick it up.

Version-Release number of selected component (if applicable):
gnash-0.7.1-7.fc6
gnash-plugin-0.7.1-7.fc6
firefox-1.5.0.6-4
firefox-1.5.0.6-4
epiphany-2.15.92-1.fc6

How reproducible:
100%

Steps to Reproduce:
1. yum install epiphany gnash-plugin
  
Actual results:
No gnash plugin available in Epiphany while its available in firefox

Expected results:
Gnash plugin available in Epiphany

Additional info:
AMD64 X2

Comment 1 Joachim Frieben 2006-09-04 08:00:31 UTC
On an IA32 system, this just works fine.

Comment 2 David Nielsen 2007-03-15 05:03:15 UTC
Upstream bug with (untested) patch to solve this. Turns out Epiphany on x86_64
it still only looks in /usr/lib when the plugins go to /usr/lib64

http://bugzilla.gnome.org/show_bug.cgi?id=407419

Comment 3 David Nielsen 2007-03-15 05:06:27 UTC
*** Bug 232384 has been marked as a duplicate of this bug. ***

Comment 4 David Nielsen 2007-03-15 05:06:36 UTC
*** Bug 232385 has been marked as a duplicate of this bug. ***

Comment 5 Bastien Nocera 2007-03-15 09:04:07 UTC
*** Bug 228480 has been marked as a duplicate of this bug. ***

Comment 6 Bastien Nocera 2007-03-16 11:15:58 UTC
The committed patch is at:
http://bugzilla.gnome.org/attachment.cgi?id=84707&action=view

The problem occurs on both FC6 and devel. Chris, let me know if I can push.

Comment 7 Bastien Nocera 2007-03-16 16:07:29 UTC
Pushed to rawhide, and FC-6 updates-testing.

Comment 8 Braden McDaniel 2007-04-01 23:19:39 UTC
*** Bug 165520 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.