Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 204 - Lilo fails to install on hd w/ multiple fat partitions
Summary: Lilo fails to install on hd w/ multiple fat partitions
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 5.2
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-26 07:22 UTC by mbrown
Modified: 2016-07-21 20:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-12-04 17:58:58 UTC


Attachments (Terms of Use)

Description mbrown 1998-11-26 07:22:25 UTC
I just recently upgraded from RH5.0 to RH5.2.  When the
install decides to install lilo, i tell it where i want to
install and which partion is the default.  (these do not
affect behavior)  Then it goes and tries to install lilo and
it comes up giving an error message "Error: unable to
install boot loader"  Then it prompts to go back or to go
the menu.

Specifically whats going on behind the install gui, is the
lilo.conf file that is being written to /mnt/etc/lilo.conf,
is invalid.  I check out the file and was surprised to find
that not only did it include my main win95 partition as a
bootable partition but also, it included every one of my
fat32 + fat16 partitions as bootable.  These others are not
and no where else in the install did I say that they were
bootable.  These were all located at the end of the file
each under its own subsection other=....

To reproduce the bug, I suggest the following:  partion a
disk w/ 1 fat32 partiton, 1 extended partition, 1 linux
partiton and 1 linux swap.  I the ext partition, make 2
fat32 partitions and 1 fat16 partitino.  Install RH 5.0.  In
disk druid, give mount points for all dos partitions.  Make
sure the only bootable partitions are the primary fat32, and
the linux partition with the linux partions set as active.
When its time to install lilo, install it in the 1st sector
of the linux partition and make linux the default.  Boot and
make sure it works.
Next, boot the rh52 install disk and do an upgrade.  Dont
add/delete new packages simply update ones already
installed.  when lilo install comes up, pick same settings
as before, you now should see the error screen.  Hit alt-f2
and take a look at the /mnt/etc/lilo.conf file its trying to
write.

Workaround:  use the rescue disk to boot into single user
mode with the root partitino mounted.  manually edit
/etc/lilo.conf (just delete the extra stuff at the bottom)
run lilo and then reboot.

Comment 1 Bill Nottingham 1998-11-30 16:03:59 UTC
*** Bug 227 has been marked as a duplicate of this bug. ***

Comment 2 David Lawrence 1998-12-04 17:58:59 UTC
I have installed a machine with the same paramters as was stated in
the bug. I then did a 5.1 fresh installaiton to the free space
consisting of root and swap partition. After that was successful I
upgraded to 5.2. This worked without a problem. It may be necessary to
see a dump of your partition information as reported by the Linux
fdisk utility.

------- Additional Comments From   12/15/98 10:01 -------
I found that this problem occurs only when using supplemental install
disk. Tested with ftp -install and CD-ROM -install with "force using
supplemental disk".
I made a minor modification in lilo.c and recompiled install2 program,
and it seems to remove the problem in both cases.
Patch posted to <bugzilla@redhat.com>.

Comment 3 openshift-github-bot 2016-07-21 20:00:57 UTC
Commit pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/5362df76caffaf57eff2b8170a40a90fa7f872be
Fix issue #204, log link throws js error


Note You need to log in before you can comment on or make changes to this bug.