Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 203678 - When dnd from firefox to nautius, nautilus crashes
Summary: When dnd from firefox to nautius, nautilus crashes
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-vfs2
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-08-23 01:36 UTC by sangu
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-30 18:59:13 UTC


Attachments (Terms of Use)
nautilus backtrace file (deleted)
2006-08-24 13:33 UTC, sangu
no flags Details
a patch (deleted)
2006-08-29 04:51 UTC, Matthias Clasen
no flags Details | Diff
Comment (deleted)
2006-08-23 01:36 UTC, sangu
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 353337 None None None Never

Description sangu 2006-08-23 01:36:48 UTC
Created attachment 915139 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).

Comment 1 Alexander Larsson 2006-08-23 13:01:20 UTC
Fixed in upstream eel cvs:

2006-08-23  Alexander Larsson  <alexl@redhat.com>

	* eel/eel-vfs-extensions.c: (eel_vfs_has_capability):
	Fix crash that happened on DnD from firefox in nautilus.


Comment 2 Alexander Larsson 2006-08-23 14:42:43 UTC
fixed in eel2 2.15.92-2.

Comment 3 sangu 2006-08-24 13:33:11 UTC
Created attachment 134806 [details]
nautilus backtrace file

This problem still happens in eel2-2.15.92-2.fc6.

Comment 4 Alexander Larsson 2006-08-25 08:47:41 UTC
Strange. It works for me. Are you sure you restarted nautilus after upgrading eel?
Can you give me the exact steps (what url and whatnot) you did to make it crash?

Comment 5 sangu 2006-08-25 09:27:05 UTC
Of course,  restarted nautilus ( linux reboot).
DnD All image file in http://art.peoplein.net/ make nautilus crash.

====
This  URL : http://www.peoplein.net/bbs/data/potrait2/Untitled_22.jpg
Drag and drop the image to nautilus.



Comment 6 Alexander Larsson 2006-08-25 13:35:39 UTC
Seems to be a gnome-vfs http bug, as this segfaults in an assert:
gnomevfs-info http://www.peoplein.net/bbs/data/potrait2/Untitled_22.jpg


Comment 7 Matthias Clasen 2006-08-28 20:59:39 UTC
The assert we are hitting here is 

  case NE_REDIRECT:
  case NE_RETRY: 
    g_assert_not_reached ();

in resolve_result.

Since NE_REDIRECT _is_ handled in the caller (http_get_file_info), it seems
that http_get_file_info needs to handle retry, too ?

Comment 8 Matthias Clasen 2006-08-29 04:51:51 UTC
Created attachment 135103 [details]
a patch

Here is a patch that makes the gnomevfs-info crash go away. 
I don't really know enough about neon to judge if it is reasonable 
or correct.

Comment 9 Alexander Larsson 2006-08-29 07:40:31 UTC
I'm not very good at this stuff either. I asked gicmo to take a look at it.

Comment 10 Matthias Clasen 2006-08-30 18:59:13 UTC
Fixed in 2.15.92-2

Comment 11 sangu 2006-08-31 11:33:09 UTC
$ gnomevfs-info http://www.peoplein.net/bbs/data/potrait2/7.jpg
Error: Too many links

When doing dnd http://www.peoplein.net/bbs/data/potrait2/7.jpg, nautius doesn't
crash. but http://www.peoplein.net/bbs/data/potrait2/7.jpg doesn't be did dnd.

Comment 12 Alexander Larsson 2006-09-01 13:00:18 UTC
I'm not sure exactly what the problem is with the link depth, see upstream bug
for discussion. However, at least it doesn't crash anymore.


Comment 13 Christian Kellner 2006-09-01 19:36:51 UTC
The problem is not the link depth but the server being "broken". See
bugzilla.gnome.org comment. Btw patch btw is in cvs head and will be in for 2.16. 


Note You need to log in before you can comment on or make changes to this bug.