Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 203568 - split out a -devel package for libsmbclient
Summary: split out a -devel package for libsmbclient
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: samba
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Simo Sorce
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: 226387
TreeView+ depends on / blocked
 
Reported: 2006-08-22 14:46 UTC by Patrice Dumas
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-25 11:42:47 UTC


Attachments (Terms of Use)

Description Patrice Dumas 2006-08-22 14:46:26 UTC
Description of problem:

The headers, .so and .a of smbclient should be in a -devel 
package. 

As a side note
/usr/include/libmsrpc.h
includes header files that are not present. Maybe it shouldn't
be shipped?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jay Fenlason 2006-10-30 19:18:08 UTC
Moving to devel for fc7. 

Comment 2 Patrice Dumas 2006-11-17 16:09:27 UTC
Maybe it is the right time to make that change
such that it leaves time to workaround things that break?

Things will break (except for samba-common itself) 
since there is:

$ repoquery --whatrequires libsmbclient.so.0
gnome-vfs2-smb-0:2.16.2-2.fc7.i386
kdebase-6:3.5.5-0.4.fc6.i386
xine-lib-0:1.1.2-17.fc7.i386
samba-common-0:3.0.23c-2.i386


Comment 3 Dmitry Butskoy 2007-04-25 11:38:26 UTC
Whether this can be closed now?

Comment 4 Patrice Dumas 2007-04-25 11:42:47 UTC
Looks like it is fixed now.


Note You need to log in before you can comment on or make changes to this bug.