Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 203539 - SMB URIs with authentication details fail
Summary: SMB URIs with authentication details fail
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
Reported: 2006-08-22 12:45 UTC by Hans de Goede
Modified: 2013-01-13 13:53 UTC (History)
1 user (show)

Fixed In Version: 0.7.61-1.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2007-03-30 15:35:07 UTC

Attachments (Terms of Use)

Description Hans de Goede 2006-08-22 12:45:11 UTC
This is sort of a duplicate of: bug 116759 . Still I'm opening a new bug because:
-bug 116759, is about the old system-config-printer and contains patches for 
 that, also bug 116759 is more then 2 years old now, so I guess it would be best
 to close bug 116759 as a dup of this one, as this bug discusses the new
 situation with the new system-config-printer
-bug 116759 talks about authentication before browsing for available smb shares,
 so that shares needing auth can be found too. I don't know if the new 
 system-config-printer does any smb browsing at all (it didn't seem too) and 
 authentication during browsing is not what this bug is about, this bug
 is about allowing authentication to a domain during the "Select Connection" 
 step of adding / modifying a printer.

The problem:
I want to print to a network printer attached to my univeristy's ads managed
network. In order to be able todo this I must specify the domain I belong to

Currently the GUI lacks a way of inputting a domain, some googleing has tought
me that using ORG/username as username does the trick. This fixes my immediate
problem of being able to print :)

However this "fix" has 2 issues:
1) its obscure and an average user won't find it.
2) It causes unwanted side effects:
 a) When you try to modify a printer from the gui which ues an smb username of
    ORG/username, then in the smb-URI the username and passwd get shown, BAD!
 b) When you try to modify the connection settings you have to re-enter all data
    presuambly because the parsing of the smb-URI fails.

Once the unwanted side effects are fixed it should be easy to add a Domain GUI
entry or atleast to add the DOMAIN/ trick to the (missing) help.

Comment 1 Hans de Goede 2006-08-22 12:48:57 UTC
I just saw bug 203149, which is clearly related to this one.

Comment 2 Tim Waugh 2006-08-22 13:59:12 UTC
The main problem I see here is this:

> I don't know if the new 
> system-config-printer does any smb browsing at all (it didn't seem too)

It is meant to browse, just like the older version.  That clearly isn't working
for you.  When you go to create a new queue using system-config-printer, and
select 'Windows Printer via SAMBA' as the connection type, the right-hand side
of the window should show a tree containing domains->hosts->queues.  So:

1. Is that not happening?
2. Did it ever work in system-config-printer 0.6.x (i.e. FC5 or earlier)?

Comment 3 Hans de Goede 2006-08-22 14:29:30 UTC
I'm on a LAB / testing network, so most likely browsing isn't working because
there is nothing to browse, or should I still get some kinda indication of
browsing then?

The ads machine I'm connecting to is on a different subnet and doesn't seem to
allow browsing without first authenticating, but that is not what this bug is
about, my problem is not being able to enter a domain when I enter the share
name manually.

Comment 4 Tim Waugh 2006-12-15 15:45:31 UTC
The SMB browsing code needs re-writing I think. :-(

Comment 5 Hans de Goede 2007-03-30 13:47:08 UTC
I've just been hit by the original bug again, can you atleast fix the issue I
was actually trying to report?

I don't care much about smb browsing!

But when I currently change properties (say papersize) of an smb printer with a
username:password encoded in the URL/URI, the username password gets replaced
with the single UTF-8 char '...' yes, a special single char containing '...' . I
think this is done when displaying the URL in the GUI to not give away the
username/password, but it gets written back this way to /etc/cups/printers.conf

This should be easy to fix!

(and it would be nice to add a username/password entry field to the dialog for
creating a new printer).

Comment 6 Tim Waugh 2007-03-30 14:36:23 UTC
Oh -- I had fixed that for FC-6, but another change in F-7 has broken that
again.  I see the problem and will work on a fix.

Comment 7 Tim Waugh 2007-03-30 15:35:07 UTC
Should be fixed in system-config-printer-0.7.61-1.fc7.

Note You need to log in before you can comment on or make changes to this bug.