Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 203536 - split a -devel package?
Summary: split a -devel package?
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: a2ps
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target 225235
TreeView+ depends on / blocked
 
Reported: 2006-08-22 11:45 UTC by Patrice Dumas
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-27 18:20:17 UTC


Attachments (Terms of Use)

Description Patrice Dumas 2006-08-22 11:45:43 UTC
Description of problem:

the a2ps package contains a library and an include file, it should
better be in a -devel package. 

The .la file is uneeded, it should be removed, as per the 
packaging guidelines.

having ogonkify included in a2ps is bad, since it is the 
same than ogonkify upstream with configure.in added, but
it may not be worth the trouble to remove it, since the
2 projects seem to work together.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Patrice Dumas 2006-11-17 15:48:40 UTC
Maybe it is the right time to move
/usr/include/liba2ps.h
/usr/lib/liba2ps.a

and remove
/usr/lib/liba2ps.la

such that it leaves time to workaround things that break?

Comment 2 Tim Waugh 2007-02-27 18:01:44 UTC
Actually I don't think we need to keep those files around at all.

Fixed in CVS.

Comment 3 Patrice Dumas 2007-02-27 18:20:17 UTC
Seems fine. They could be re-added later if needed anyway.
I close rawhide, feel free to reopen and reclose if you think
there is a better resolution.


Note You need to log in before you can comment on or make changes to this bug.