Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2033 - PC keyboards on sparc64
Summary: PC keyboards on sparc64
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-07 15:53 UTC by Cristian Gafton
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-04 16:49:33 UTC


Attachments (Terms of Use)

Description Cristian Gafton 1999-04-07 15:53:13 UTC
The installer correctly found my PS/2 mouse on my
sparc64/PCI system, and configured XF86Config appropriately.
Yet it did not detect that I also had a PC Keyboard, thus
XF86Config was left with "sun" as the keyboard type which
obviously didn't work.

A quick hack solution (which would work fully) would be
to put:

   XkbRules    "xfree86"
   XkbModel    "pc101"
   XkbLayout   "us"

Into XF86Config's keyboard section if a PS/2 mouse is found,
because to my knowledge there is no way to have a PS/2 mouse
in an Ultra/PCI system and not have a PC Keyboard attached
as well.

Comment 1 Preston Brown 1999-04-08 17:29:59 UTC
I believe Matt has fixed this.  Matt if not, please reopen.

Comment 2 David Miller 1999-04-13 09:00:59 UTC
The problem is still there in the current build.

Comment 3 Preston Brown 1999-04-13 18:15:59 UTC
Dave:

I think I have fixed this, it is hard to test because we don't have a
box locally.  I switched the test from strcasecmp to strcasestr
looking for "ps/2" as the mouse type, as I am assuming that it may be
getting set to something like "generic3ps/2" or something similar in
mouseconfig -- if we could see /etc/sysconfig/mouse it would be nice.
In any case, please give Xconfigurator 4.1.6 a whirl, and report back.


Note You need to log in before you can comment on or make changes to this bug.