Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 202395 - {%includedir,%libdir}/firefox-* should not include minor version
Summary: {%includedir,%libdir}/firefox-* should not include minor version
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target 223880
TreeView+ depends on / blocked
 
Reported: 2006-08-14 04:16 UTC by Jens Petersen
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-01 18:47:12 UTC


Attachments (Terms of Use)

Description Jens Petersen 2006-08-14 04:16:51 UTC
Description of problem:
Firefox installs lots of files under $libdir/firefox-$VERSION, where
VERSION is the full version (eg 1.5.0.6).
It would be better if it just used the major version or even no version
at all i think.  Presumably the API doesn't break for every minor release?

Steps to Reproduce:
1. rpm -q firefox
2. rpm -ql firefox firefox-devel | grep `rpm -q --qf "%{name}-%{version}" firefox`$
  
Actual results:
/usr/lib/firefox-1.5.0.6
/usr/include/firefox-1.5.0.6
/usr/share/idl/firefox-1.5.0.6

Expected results:
/usr/lib/firefox-1.5
/usr/include/firefox-1.5
/usr/share/idl/firefox-1.5

Additional info:
Debian uses
/usr/lib/firefox
/usr/include/firefox
for example.

Some -devel packages which link to libgtkembedmoz need to be rebuilt
for every minor firefox update because of this.

Comment 1 Christopher Aillon 2006-09-01 18:47:12 UTC
It is a pain, but they break and need to be rebuilt anyway because ABI does
indeed change unfortunately from time to time.

Comment 2 Jens Petersen 2007-03-20 07:27:42 UTC
For a project of the size and importance of mozilla this seems unreasonable.

Any plans to address this upstream?

Comment 3 Christopher Aillon 2007-03-20 14:55:28 UTC
xulrunner.

Comment 4 Jens Petersen 2007-03-21 01:41:59 UTC
Would that help packages using libgtkembedmoz?

Comment 5 Christopher Aillon 2007-03-21 02:03:22 UTC
yes


Note You need to log in before you can comment on or make changes to this bug.