Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2020 - dvorak keyboard mistake
Summary: dvorak keyboard mistake
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: distribution
Version: 5.2
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-06 06:45 UTC by hfelton
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-05 18:04:07 UTC


Attachments (Terms of Use)

Description hfelton 1999-04-06 06:45:18 UTC
For telinit:3 - dvorak keyboard is perfect.

For telinit:5 - any xterm (regardless of wm) has an error.

There does not seem to be any xmodmap or other item that
should cause this problem.

Problem: key "+/=" and key "}]" are reversed.

Note - the "_-" and "{[" keys are fine.  All other keys,
especially punctuation, are left intact for dvorak.  It
appears that the above two keys are somehow converted back
to their qwerty-locations.

I am using a 101-key (not 104, with windows), large-pin
(not ps2) keyboard on a 486.

I tried searching for keyword "dvorak" in bugzilla and
no matches came up - so I assume that this is a new bug.

Any help - or insights - would be appreciated.  I am very
hesitant to run xmodmap for just these two keys, since I
do not understand what is really happening.

I do greatly appreciate the fact that dvorak was an option
in the original installation and it was working fine until
I turned on Xwindows.  Since I am a programmer, the two
keys mentioned above are fairly common ones.

Sincerely, Harold.

Comment 1 David Lawrence 1999-04-06 17:52:59 UTC
Make sure that you have the initscript enabled for keytable for
runlevel 5. To do this do ls -al /etc/rc.d/rc5.d/ and make sure there
is a line with S**keytable (** is some number like 75, etc.). If you
do not then run

chkconfig --level 2345 keytable on

Comment 2 hfelton 1999-04-08 08:01:59 UTC
This bug is not resolved.

I have been going thru the long/painful process of reformatting
my hard drive with a low-level scan and have not had a chance
to double check the comment that was emailed, but I believe it
is incorrect.

The dvorak keyboard IS working in telinit:5, EXCEPT for two keys,
which have somehow been reset.

The "solution" does not make sense for solving this problem.
Unfortunately, I cannot test to be sure for another day or two.

Sincerely, Harold.

Comment 3 hfelton 1999-04-12 22:19:59 UTC
Well, I finally got around to checking on this again.

/etc/rc.d/rc5.d/S75keytable is a link to ../init.d/keytable
which is a shell script that checks /etc/sysconfig/keyboard
and uses /usr/bin/loadkeys to do the keyboard translation.

/etc/sysconfig/keytable only has the line KEYTABLE=dvorak
and /usr/bin/loadkeys is binary data.

Again, the problem seems to be some form of reset for
the two keys "]/}" and "=/+" only.  If I am doing my
initial login and running within bash, they are fine.
As soon as I do a startx or telinit-5, then the xterm
windows have them reversed.  All the other keys are ok.

Ideas?  I would even live (at this point) with a valid
workaround, so if you have one of those - please send it.

Sincerely, Harold.

Comment 4 hfelton 1999-04-22 05:56:59 UTC
Has anyone else, besides me, been able to reproduce this problem?
I am not installing Linux on my other PC if I cannot get dvorak
to work correctly.  ie - is it Linux, or Redhat ???

------- Email Received From  pbrown@redhat.com 04/22/99 02:01 -------


------- Additional Comments From   04/22/99 22:25 -------
Howdee,I found an answer that should be published along with this bug,so that someone else searching thru the archive sees it.  ie -...then change the following lines in '/usr/lib/X11/xkb/symbols/dvorak'key <AE12> { [ equal, plus ] };key <AD12> { [ bracketright, braceright ] };tokey <AE12> { [ bracketright, braceright ] };key <AD12> { [ equal, plus ] };to correct the keymapping error which has ']/}' and '=/+' in the wrongorder....which I found at http://vancouver-webpages.com/vanlug/1998-2/0180.htmland exactly solves the problem without using xmodmap.Thanx anyway and I hope someone else gets info from this.I tried this at home and it worked perfectly.I guess we can call this bug closed now.Sincerely, Harold.

Comment 5 Jeff Johnson 1999-06-05 18:04:59 UTC
THe patch XFree86-3.3.3.1-dvorak.patch in the src.rpm
appears to fix this problem. That patch will be available in
(at least) XFree86-3.3.3.1-50. I think the fix was also
added in Red hat 6.0, but I might be wrong.


Note You need to log in before you can comment on or make changes to this bug.