Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 201244 - yum FAILS to update the system if it believes it is back from future or in future
Summary: yum FAILS to update the system if it believes it is back from future or in fu...
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 5
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
Reported: 2006-08-03 19:11 UTC by hanishkvc
Modified: 2014-01-21 22:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2006-09-18 20:58:08 UTC

Attachments (Terms of Use)

Description hanishkvc 2006-08-03 19:11:05 UTC
Description of problem: If for some reason a computer's date is set to future
and then yum update is run. And LATER reset the computer date to proper current
date YUM no longer updates the system with new updated packages. (Happened when
my RTC battery went down and I wrongly set the clock to 2009 once and ran yum
update later even after fixing the date in computer, for few days I found yum
not updating my system and on probing found this issue. I FIXED this by clearing
ALL the cache maintained by yum) 

Version-Release number of selected component (if applicable):
Was two to three weeks back (didn't get time to report before)

How reproducible:
I haven't tried repeating later but this is the steps that had lead to the
problem for me.

Steps to Reproduce:
1. Set the clock in computer (bios level during initial boot) to 2009
2. login into FC5, run yum update (was in this wrong date for one or two days)
3. Reset the computer and reset the clock to proper current date in bios
4. login into FC5 and run yum update. 
NOTE 1. I noticied that atleast for 3 to 4 days after this nothing was updating
in my system, but on checking fedora website it had shown new updates, then on
checking I released the 2009 date goof up thro time info in /var/cache related
to yum and HAD to clear all cache thro/of yum and only then yum update started
Actual results:
system not getting updated with new updated packages

Expected results:
system should get updated with new updated packages, independent of whether its
clock is set to future or the yum believes it has gone to future and come back .

Additional info:
As I have already mentioned I haven't tried repeating the same setup later. But
it did occur to me and surprised me that suddenly FC5 didn't have any new
updated packages for few days ;-)

Comment 1 hanishkvc 2006-08-03 20:48:28 UTC
On verifing further now, even if just the cachecookie files in /var/cache
related to yum have a time in future. Yum doesn't seem to check for updates for
that particular repository. I will verify if the same issue persists tomorrow
also and then inform back. - hanishkvc

Comment 2 Seth Vidal 2006-08-19 19:41:02 UTC
Any update on this?

Comment 3 Jeremy Katz 2006-09-18 20:58:08 UTC
Closing due to inactivity

Note You need to log in before you can comment on or make changes to this bug.