Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2010 - log xdm (gdm/kdm) logins to utmpx/wtmp and /var/log/messages
Summary: log xdm (gdm/kdm) logins to utmpx/wtmp and /var/log/messages
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
: 2366 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-05 20:07 UTC by stewart
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-17 14:20:26 UTC


Attachments (Terms of Use)

Description stewart 1999-04-05 20:07:27 UTC
This might go somewhere else, not certain excatly where.

Can the default behaviour of xdm/gdm (not certain about kdm)
be changed so that whenever a user logs in an entry is put
in utmpx/wtmp (for w, finger, last) as well as going in
/var/log/messages.  It makes it much nicer for tracking
users down.  It is nice to see entries in /var/log/secure

Comment 1 Preston Brown 1999-05-17 14:20:59 UTC
XFree86 3.3.3.1 build 49 and higher include this feature in
/etc/X11/xdm/GiveConsole and TakeConsole.  Any *dm that uses these
files will automatically have this feature then; this includes xdm and
kdm.

gdm does things entirely on its own, it doesn't use these legacy
configuration files.  Please make a suggestion to the GNOME developers
to add this feature to their display manager.

Comment 2 Jeff Johnson 1999-06-03 15:40:59 UTC
*** Bug 2366 has been marked as a duplicate of this bug. ***

When logging into RH Linux via xdm the lastlog files are
not updated.  Thus, a 'w' or 'who' command would show the
user as logged in, but a finger of the user would not show
them as logged in.

------- Additional Comments From scott@mehosky.com  05/09/99 17:20 -------
I have had this problem on several Red Hat systems.


Note You need to log in before you can comment on or make changes to this bug.