Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 200682 - hal unable to handle USB Printer
Summary: hal unable to handle USB Printer
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hal-cups-utils
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-07-30 19:30 UTC by John Himpel
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: 0.6.2-3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-04 10:30:16 UTC


Attachments (Terms of Use)
output from lshal (deleted)
2006-07-30 19:30 UTC, John Himpel
no flags Details
output from system-config-printer (deleted)
2006-08-01 20:29 UTC, John Himpel
no flags Details

Description John Himpel 2006-07-30 19:30:59 UTC
Description of problem:
Hal not recognizing USB printer

Version-Release number of selected component (if applicable):
hal-0.5.7.1-2.fc6
dbus-0.90-8
cups-1.2.2-4
kernel-PAE-2.6.17-1.2462.fc6

How reproducible:
System->Administration->Printing
Select printer
click on "enabled"
click on "apply"


Steps to Reproduce:
1.
2.
3.
  
Actual results:
E [30/Jul/2006:14:22:19 -0500] cupsdAcceptClient: skipping getpeercon()
E [30/Jul/2006:14:22:19 -0500] cupsdAcceptClient: skipping getpeercon()
I [30/Jul/2006:14:22:19 -0500] Saving printers.conf...
I [30/Jul/2006:14:22:19 -0500] Printer "DESKJET_880C" started by "root".
I [30/Jul/2006:14:22:19 -0500] Started filter /usr/lib/cups/filter/pstops (PID
3046) for job 143.
I [30/Jul/2006:14:22:19 -0500] Started filter /usr/lib/cups/filter/foomatic-rip
(PID 3047) for job 143.
I [30/Jul/2006:14:22:19 -0500] Started backend /usr/lib/cups/backend/hal (PID
3048) for job 143.
E [30/Jul/2006:14:22:19 -0500] [Job 143] Unable to open HAL device
"hal:/org/freedesktop/Hal/devices/usb_device_3f0_104_MY93N151ZNGE_if0_printer_MY93N151ZNGE"
E [30/Jul/2006:14:22:19 -0500] PID 3048 (/usr/lib/cups/backend/hal) stopped with
status 1!
I [30/Jul/2006:14:22:19 -0500] Hint: Try setting the LogLevel to "debug" to find
out more.
E [30/Jul/2006:14:22:21 -0500] PID 3047 (/usr/lib/cups/filter/foomatic-rip)
stopped with status 9!
I [30/Jul/2006:14:22:21 -0500] Hint: Try setting the LogLevel to "debug" to find
out more.
I [30/Jul/2006:14:22:21 -0500] [Job 143] Backend returned status 1 (failed)
I [30/Jul/2006:14:22:21 -0500] Saving printers.conf...


Expected results:


Additional info:
Similar to bug filed last week, but that bug was resolved via rawhide update and
correctly closed.  This ia a new report with the latest rawhide (7/30/06) applied.

Comment 1 John Himpel 2006-07-30 19:30:59 UTC
Created attachment 133294 [details]
output from lshal

Comment 2 John (J5) Palmieri 2006-07-31 15:25:22 UTC
Looks like it is missing the "//" in the protocol URI element (i.e. it should be
hal:// not just hal: so
hal:///org/freedesktop/Hal/devices/usb_device_3f0_104_MY93N151ZNGE_if0_printer_MY93N151ZNGE
would be the correct URI).  Reasigning to system-config-printer.

Comment 3 Tim Waugh 2006-08-01 09:25:25 UTC
hal_lpadmin problem perhaps (from hal-cups-utils)

Comment 4 Tim Waugh 2006-08-01 09:38:26 UTC
I've built hal-cups-utils-0.6.2-3 with this patch:

--- hal-cups-utils-0.6.2/systemv/hal_lpadmin.uri        2006-08-01
10:39:39.000000000 +0100
+++ hal-cups-utils-0.6.2/systemv/hal_lpadmin    2006-08-01 10:44:03.000000000 +0100
@@ -41,11 +41,11 @@
         return name.replace("#", "_")

     def get_cups_uris(self):
-        return ["hal:%s" % self.uid,
+        return ["hal://%s" % self.uid,
                 ]

     def get_cups_uri(self):
-        return "hal:%s" % self.uid
+        return "hal://%s" % self.uid

     def match(self, printer):
         if printer.is_class: return False

so hopefully that will fix it.

Comment 5 John Himpel 2006-08-01 20:29:08 UTC
Created attachment 133438 [details]
output from system-config-printer


Note You need to log in before you can comment on or make changes to this bug.