Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 200638 (cpufreqlockdep) - BUG: warning at kernel/cpu.c:38/lock_cpu_hotplug()
Summary: BUG: warning at kernel/cpu.c:38/lock_cpu_hotplug()
Keywords:
Status: CLOSED RAWHIDE
Alias: cpufreqlockdep
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
: 200306 (view as bug list)
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-07-29 14:29 UTC by Konstantin Ryabitsev
Modified: 2015-01-04 22:28 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-11 00:35:22 UTC


Attachments (Terms of Use)

Description Konstantin Ryabitsev 2006-07-29 14:29:46 UTC
Description of problem:
For a while now, booting on Mac Intel Mini (solo) has been giving me this
non-fatal TB:

...
Lukewarm IQ detected in hotplug locking
BUG: warning at kernel/cpu.c:38/lock_cpu_hotplug() (Not tainted)
 [<c04051ea>] show_trace_log_lvl+0x54/0xfd
 [<c04057a6>] show_trace+0xd/0x10
 [<c04058bf>] dump_stack+0x19/0x1b
 [<c043f2d3>] lock_cpu_hotplug+0x49/0x6f
 [<c04338e3>] __create_workqueue+0x52/0x116
 [<f8c0134b>] cpufreq_governor_dbs+0x9f/0x2c3 [cpufreq_ondemand]
 [<c05a1e8f>] __cpufreq_governor+0x57/0xd8
 [<c05a204d>] __cpufreq_set_policy+0x13d/0x1a9
 [<c05a225f>] store_scaling_governor+0x12d/0x15b
 [<c05a18e0>] store+0x37/0x48
 [<c04a8db4>] sysfs_write_file+0xab/0xd1
 [<c0471ffb>] vfs_write+0xab/0x157
 [<c0472640>] sys_write+0x3b/0x60
 [<c0403faf>] syscall_call+0x7/0xb
...


Version-Release number of selected component (if applicable):
icon@mini:[~]$ uname -r
2.6.17-1.2462.fc6

How reproducible:
Every boot.

Comment 1 Dave Jones 2006-07-29 17:36:09 UTC
This is the new flavour of the bug referenced in 197803
It's being worked on.


Comment 2 Dave Jones 2006-07-31 23:35:32 UTC
*** Bug 200306 has been marked as a duplicate of this bug. ***

Comment 3 Joachim Frieben 2006-08-01 06:38:03 UTC
*** This bug should have been marked as a duplicate of bug 200306
since 200306 < 200638, right?  ***

Comment 4 Dave Jones 2006-08-02 02:00:22 UTC
not necessarily. there's no rule that bugs must be duped one way or the other.


Comment 5 Ronald Warsow 2006-08-02 13:47:14 UTC
kernel 2.6.17-1.2488.fc6

...
=============================================
[ INFO: possible recursive locking detected ]
---------------------------------------------
vol_id/903 is trying to acquire lock:
 (&md->io_lock){----}, at: [<e08ce48e>] dm_request+0x18/0xea [dm_mod]

but task is already holding lock:
 (&md->io_lock){----}, at: [<e08ce48e>] dm_request+0x18/0xea [dm_mod]

other info that might help us debug this:
1 lock held by vol_id/903:
 #0:  (&md->io_lock){----}, at: [<e08ce48e>] dm_request+0x18/0xea [dm_mod]

stack backtrace:
 [<c04051ee>] show_trace_log_lvl+0x58/0x159
 [<c0405802>] show_trace+0xd/0x10
 [<c040591b>] dump_stack+0x19/0x1b
 [<c043b842>] __lock_acquire+0x773/0x997
 [<c043bfd7>] lock_acquire+0x4b/0x6c
 [<c0439030>] down_read+0x2d/0x40
 [<e08ce48e>] dm_request+0x18/0xea [dm_mod]
 [<c04d5169>] generic_make_request+0x28c/0x29c
 [<e08cd44c>] __map_bio+0xc1/0xef [dm_mod]
 [<e08cdd27>] __split_bio+0x159/0x3a1 [dm_mod]
 [<e08ce552>] dm_request+0xdc/0xea [dm_mod]
 [<c04d5169>] generic_make_request+0x28c/0x29c
 [<c04d6f92>] submit_bio+0xb1/0xb8
 [<c04735dd>] submit_bh+0xfc/0x11b
 [<c0475eda>] block_read_full_page+0x2c3/0x2d3
 [<c047868d>] blkdev_readpage+0xf/0x11
 [<c045af57>] __do_page_cache_readahead+0x15f/0x1af
 [<c045aff1>] blockable_page_cache_readahead+0x4a/0x9f
 [<c045b1eb>] page_cache_readahead+0x112/0x174
 [<c0455a85>] do_generic_mapping_read+0x12b/0x451
 [<c04565b5>] __generic_file_aio_read+0x187/0x1e8
 [<c045756c>] generic_file_read+0x87/0x9b
 [<c04723ec>] vfs_read+0xa9/0x155
 [<c047287c>] sys_read+0x3b/0x60
 [<c0403faf>] syscall_call+0x7/0xb
DWARF2 unwinder stuck at syscall_call+0x7/0xb
Leftover inexact backtrace:
 [<c0405802>] show_trace+0xd/0x10
 [<c040591b>] dump_stack+0x19/0x1b
 [<c043b842>] __lock_acquire+0x773/0x997
 [<c043bfd7>] lock_acquire+0x4b/0x6c
 [<c0439030>] down_read+0x2d/0x40
 [<e08ce48e>] dm_request+0x18/0xea [dm_mod]
 [<c04d5169>] generic_make_request+0x28c/0x29c
 [<e08cd44c>] __map_bio+0xc1/0xef [dm_mod]
 [<e08cdd27>] __split_bio+0x159/0x3a1 [dm_mod]
 [<e08ce552>] dm_request+0xdc/0xea [dm_mod]
 [<c04d5169>] generic_make_request+0x28c/0x29c
 [<c04d6f92>] submit_bio+0xb1/0xb8
 [<c04735dd>] submit_bh+0xfc/0x11b
 [<c0475eda>] block_read_full_page+0x2c3/0x2d3
 [<c047868d>] blkdev_readpage+0xf/0x11
 [<c045af57>] __do_page_cache_readahead+0x15f/0x1af
 [<c045aff1>] blockable_page_cache_readahead+0x4a/0x9f
 [<c045b1eb>] page_cache_readahead+0x112/0x174
 [<c0455a85>] do_generic_mapping_read+0x12b/0x451
 [<c04565b5>] __generic_file_aio_read+0x187/0x1e8
 [<c045756c>] generic_file_read+0x87/0x9b
 [<c04723ec>] vfs_read+0xa9/0x155
 [<c047287c>] sys_read+0x3b/0x60
 [<c0403faf>] syscall_call+0x7/0xb
FDC 0 is a post-1991 82077
PM: Adding info for platform:floppy.0
DVB: registering frontend 0 (Philips TDA10046H DVB-T)...
budget-av: ci interface initialised.
PM: Adding info for No Bus:i2c-1
ACPI: PCI Interrupt 0000:00:11.5[C] -> GSI 22 (level, low) -> IRQ 201
PCI: Setting latency timer of device 0000:00:11.5 to 64
PM: Adding info for ac97:0-0:ALC850
PCI: Enabling device 0000:00:11.6 (0000 -> 0001)
ACPI: PCI Interrupt 0000:00:11.6[C] -> GSI 22 (level, low) -> IRQ 201
PCI: Setting latency timer of device 0000:00:11.6 to 64
ACPI: PCI interrupt for device 0000:00:11.6 disabled
VIA 82xx Modem: probe of 0000:00:11.6 failed with error -13
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378, irq 7 [PCSPP]
lp0: using parport0 (interrupt-driven).
lp0: console ready
ACPI: Power Button (FF) [PWRF]
ACPI: Power Button (CM) [PWRB]
ACPI: Sleep Button (CM) [SLPB]
ibm_acpi: ec object not found
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
EXT3 FS on sda6, internal journal
Adding 1052248k swap on /dev/dm-3.  Priority:-1 extents:1 across:1052248k
Lukewarm IQ detected in hotplug locking
BUG: warning at kernel/cpu.c:38/lock_cpu_hotplug() (Not tainted)
 [<c04051ee>] show_trace_log_lvl+0x58/0x159
 [<c0405802>] show_trace+0xd/0x10
 [<c040591b>] dump_stack+0x19/0x1b
 [<c043f38f>] lock_cpu_hotplug+0x49/0x6f
 [<c04338e3>] __create_workqueue+0x52/0x116
 [<e0be134b>] cpufreq_governor_dbs+0x9f/0x2c3 [cpufreq_ondemand]
 [<c05a20a7>] __cpufreq_governor+0x57/0xd8
 [<c05a2265>] __cpufreq_set_policy+0x13d/0x1a9
 [<c05a2477>] store_scaling_governor+0x12d/0x15b
 [<c05a1af8>] store+0x37/0x48
 [<c04a8fb4>] sysfs_write_file+0xab/0xd1
 [<c0472297>] vfs_write+0xab/0x157
 [<c04728dc>] sys_write+0x3b/0x60
 [<c0403faf>] syscall_call+0x7/0xb
DWARF2 unwinder stuck at syscall_call+0x7/0xb
Leftover inexact backtrace:
 [<c0405802>] show_trace+0xd/0x10
 [<c040591b>] dump_stack+0x19/0x1b
 [<c043f38f>] lock_cpu_hotplug+0x49/0x6f
 [<c04338e3>] __create_workqueue+0x52/0x116
 [<e0be134b>] cpufreq_governor_dbs+0x9f/0x2c3 [cpufreq_ondemand]
 [<c05a20a7>] __cpufreq_governor+0x57/0xd8
 [<c05a2265>] __cpufreq_set_policy+0x13d/0x1a9
 [<c05a2477>] store_scaling_governor+0x12d/0x15b
 [<c05a1af8>] store+0x37/0x48
 [<c04a8fb4>] sysfs_write_file+0xab/0xd1
 [<c0472297>] vfs_write+0xab/0x157
 [<c04728dc>] sys_write+0x3b/0x60
 [<c0403faf>] syscall_call+0x7/0xb
ip_tables: (C) 2000-2006 Netfilter Core Team
Time: acpi_pm clocksource has been installed.

...

more info needed ???

Comment 7 Ronald Warsow 2006-08-02 16:39:59 UTC
no change with kernel 2.6.17-1.2505.fc6

Comment 8 Jay Cliburn 2006-08-05 23:17:48 UTC
No change with kernel 2.6.17-1.2527.fc6 x86_64


Comment 9 Dave Jones 2006-08-08 18:26:49 UTC
*** Bug 201729 has been marked as a duplicate of this bug. ***

Comment 10 Ronald Warsow 2006-08-10 16:10:38 UTC
dmesg from 2.6.17-1.2543.fc6:

the lines starting with
Lukewarm IQ detected in hotplug locking
-BUG: warning at kernel/cpu.c:43/lock_cpu_hotplug() (Not tainted)
...
and the following
-DWARF2 unwinder stuck at syscall_call+0x7/0xb
-Leftover inexact backtrace:
...
are gone (for me) !
thx


Comment 11 Dave Jones 2006-08-11 00:35:22 UTC
This should finally be fixed.


Comment 12 Ronald Warsow 2006-08-27 18:45:49 UTC
vol_id/903 is trying to acquire lock
...

is still alive with 2.6.17-1.2586.fc6!

is this part handled on another bz ?



Comment 13 Ronald Warsow 2006-09-04 00:02:21 UTC
today i wrote a bz.
bz 205085




Note You need to log in before you can comment on or make changes to this bug.