Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 200507 - rhythmbox displays wrong genre tag
Summary: rhythmbox displays wrong genre tag
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: easytag
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-28 09:13 UTC by Steve
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: easytag-1.99.13-3.fcX
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-20 10:15:57 UTC


Attachments (Terms of Use)

Description Steve 2006-07-28 09:13:32 UTC
Description of problem:


Version-Release number of selected component (if applicable):
gstreamer-0.10.9-1
gstreamer-tools-0.10.9-1
gstreamer-plugins-base-0.10.9-1
gstreamer-plugins-good-0.10.3-4
gstreamer-plugins-ugly-0.10.2-1.lvn5
gstreamer-ffmpeg-0.10.1-1.fc5.rf

How reproducible:
if importing folders with sound, rhythmbox imports but displays wrong genre of
some files.

Steps to Reproduce:
1. start rhythmbox
2. import some sound
3. show "genre browser view"
  
Actual results:
rhythmbox displays wrong genre tag

Expected results:


Additional info:
affects only in fc6(rawhide)

Comment 1 Steve 2006-07-28 09:15:31 UTC
sorry forgot: rhythmbox-0.9.5-2

Comment 2 Steve 2006-07-28 11:04:58 UTC
affects not just in rawhide, also in fc5 with newest rpms installed

Comment 3 Steve 2006-11-16 11:47:28 UTC
here are two files, both are tagged with "Chillout".

https://thebc.ch/files_tmp/1.mp3    shows "Chillout/Lounge/Ambient"
https://thebc.ch/files_tmp/2.mp3    shows "Lounge"

easytag-1.99.12-3.fc6
rhythmbox-0.9.6-2.fc7

Comment 4 Steve 2006-11-22 16:05:26 UTC
The problem exists further in rhythmbox-0.9.6-3.fc7.

Comment 5 Bastien Nocera 2007-02-02 12:08:53 UTC
$ gst-launch -t filesrc location=/tmp/1.mp3 ! decodebin ! fakesink
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
FOUND TAG      : found by element "id3demux0".
           title: Stargazer - Proclamation
          artist: Ayurveda - Buddha Lounge
           album: Volume 01
            date: 2001-01-01
    track number: 1
     track count: 14
           genre: Chillout
        duration: 231000000000
FOUND TAG      : found by element "apedemux0".
           title: Stargazer - Proclamation
    track number: 1
           album: Ayurveda Buddha Lounge Vol.1
            date: 2001-01-01
          artist: Various Artists
           genre: Chillout/Lounge/Ambient

$ gst-launch -t filesrc location=/tmp/2.mp3 ! decodebin ! fakesink
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
FOUND TAG      : found by element "id3demux0".
           title: Always Mine
          artist: Cafe Del Mar
           album: Rue De Soleil - Essential Feel
            date: 2005-01-01
    track number: 1
     track count: 13
           genre: Chillout
        duration: 379000000000
FOUND TAG      : found by element "apedemux0".
           album: Rue De Soleil - Essential Feelings
            date: 2005-01-01
           genre: Lounge
           title: Always Mine
    track number: 1
          artist: Cafe Del Mar
         comment: www.eMulenl.com

There's both ID3 and APE tags in your files. Rhythmbox will choose the last one
to appear, which I don't think is any worse than choosing the first one...

Easytag probably doesn't handle MP3s with multiple tag sets very well,
reassigning to Easytag.

Comment 6 Steve 2007-02-11 09:16:02 UTC
The problem appears also in easytag-1.99.13-1.fc6...

Comment 7 Matthias Saou 2007-02-12 10:44:18 UTC
Interesting. Thanks Bastien for tracking down the problem.
I've just sent an email to the Easytag author, who has always been quite fast to
fix and enhance his application.

Comment 8 Matthias Saou 2007-02-19 10:58:51 UTC
The Easytag author has sent me a patch which simply removes the APE tag when
tagging MP3 files, and only leaves the new ID3 tag. This should solve this
issue. I've tested it with your two files, and it works as expected.
Patched easytag packages will be available for FC-6 and devel after they get
pushed (easytag-1.99.13-3.fcX).

You will need to re-tag all of your existing files which have out of sync APE
vs. ID3 tags, though... but using Bastien's gst pipeline from above, it should
be fairly easy to report all *.mp3 files which have an APE tag.

Comment 9 Steve 2007-02-19 11:18:46 UTC
thanks all you guys for the great work! i will test (or use) it after they are
in the updates...

Comment 10 Steve 2007-02-20 10:03:30 UTC
it does not really works. i must give first another genre to give afterwards the
correct. it is the meaning of?

Comment 11 Matthias Saou 2007-02-20 10:08:12 UTC
Unfortunately yes. If you only open the file, but don't change anything
"explicitly", easytag doesn't want to save them since they're "unchanged". It's
only when you make a change that it will save the files, with the APE tag removed.

Basically, it'll fix the case where you change the tags of files that have both
ID3 and APE tags, which is what you did originally. But for existing files where
both tags are "out of sync", you'll have to indeed change and save them in
easytag, then change them back and save them again...

Comment 12 Steve 2007-02-20 10:15:57 UTC
ok, so i would say: ticket closed!

thx a lot...


Note You need to log in before you can comment on or make changes to this bug.