Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 200409 - [olpc] panic in ext3 code on geode using i686 code
Summary: [olpc] panic in ext3 code on geode using i686 code
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: FC6Target FC6Blocker OLPCBlocker OLPCTracker
TreeView+ depends on / blocked
 
Reported: 2006-07-27 15:11 UTC by David Zeuthen
Modified: 2013-03-06 03:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-01 23:30:31 UTC


Attachments (Terms of Use)
photograph of panic (deleted)
2006-07-27 15:11 UTC, David Zeuthen
no flags Details

Description David Zeuthen 2006-07-27 15:11:00 UTC
Description of problem:

Kernel panic. See attached photograph. This might very well be related to i686
weirdness as described in bug 200330. My guess right now is binutils weirdness
breaking i686 for the AMD Geode.

Version-Release number of selected component (if applicable):

2.6.17-1.2449.fc6

How reproducible:

Run some file system intensive code like 'yum -y install wget'. Reproducible on
build45 on OLPC available here
 http://olpc.download.redhat.com/olpc/streams/development/build45-20060726_1718/images-rpm/olpc-stream-development-45-20060726_1718-rpm-ext3.img.bz2

bunzip2 the image, dd it to a USB stick (e.g. /dev/sda) with at least 512MB of
space and boot it on a OLPC developer boards. We have one such board in the
Westford office.

Comment 1 David Zeuthen 2006-07-27 15:11:02 UTC
Created attachment 133158 [details]
photograph of panic

Comment 2 Alexandre Oliva 2006-07-27 18:35:03 UTC
Doesn't appear to be related.  The code at the crash point is:

c04748d4:       e8 be f7 ff ff          call   c0474097 <unmap_underlying_metadata>
c04748d9:       8b 5b 04                mov    0x4(%ebx),%ebx   <=== crashes here

I'd guess that %ebx ended up with an invalid address, for whatever reason. 
Without the top of the Oops, it's hard to tell more.  It's definitely not an
illegal instruction.

Comment 3 Alexandre Oliva 2006-07-27 18:38:14 UTC
It might actually have to do with i686 instructions, though, if some replacement
chunk of code for instructions missing on the Geode turn out to corrupt %ebx or
whatever memory slot it happened to be preserved in by the callee.

Comment 4 Christopher Blizzard 2006-08-01 23:22:56 UTC
Do we still see this panic after the rebuild with the new binutils?

Comment 5 David Zeuthen 2006-08-01 23:30:31 UTC
No, this seems to be fixed. Closing. Thanks.


Note You need to log in before you can comment on or make changes to this bug.