Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 200205 - snmp backend times out
Summary: snmp backend times out
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 5
Hardware: athlon
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-07-26 07:04 UTC by Joachim Backes
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 1.2.2-1.8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-30 16:08:59 UTC


Attachments (Terms of Use)
strace /usr/lib/cups/backend/snmp (deleted)
2006-07-28 04:36 UTC, Joachim Backes
no flags Details
CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp >snmp.log 2>&1 (deleted)
2006-07-31 05:01 UTC, Joachim Backes
no flags Details
CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp (deleted)
2006-08-01 13:10 UTC, Joachim Backes
no flags Details
CUPS_DEBUG_LEVEL=3 strace /usr/lib/cups/backend/snmp 2>&1 | tee snmp.log (deleted)
2006-08-02 04:51 UTC, Joachim Backes
no flags Details

Description Joachim Backes 2006-07-26 07:04:18 UTC
Description of problem:
Trying to admin my cps server by "firefox localhost:613". The brwoser window is
displayed, but if clicking the "Administration" tab lets it hang. Inspecting
/var/log/cups/error_log show 3 lines:

W [26/Jul/2006:09:11:00 +0200] [cups-deviced] Backend "snmp" did not respond
within 30 seconds!
W [26/Jul/2006:09:11:18 +0200] [cups-deviced] Backend "snmp" did not respond
within 30 seconds!
W [26/Jul/2006:09:11:29 +0200] [cups-deviced] Backend "snmp" did not respond
within 30 seconds!


Version-Release number of selected component (if applicable):
cups-1.2.1-1.7

How reproducible:
Each time

Steps to Reproduce:
1.Start firefox on the cups server: "forefox localhost:631"
2.Click the "Adminstration" tab
3.
  
Actual results:
It hangs

Expected results:
open the admin window or the root authentification prompt

Additional info:--

Comment 1 Tim Waugh 2006-07-27 13:22:14 UTC
A new CUPS package for FC5 was made available yesterday:

https://www.redhat.com/archives/fedora-package-announce/2006-July/msg00097.html

Please try that package (just 'yum update') and let me know if the problem is
still present.

Thanks.

Comment 2 Joachim Backes 2006-07-27 13:37:06 UTC
Has already been installed (cups-1.2.2-1.1), but did not help.
Tailing /var/log/cups/error_log:

I [27/Jul/2006:15:46:12 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=3752)
I [27/Jul/2006:15:46:12 +0200] Started "/usr/lib/cups/daemon/cups-deviced"
(pid=3753)
W [27/Jul/2006:15:46:45 +0200] [cups-deviced] Backend "snmp" did not respond
within 30 seconds!


Comment 3 Tim Waugh 2006-07-27 15:59:07 UTC
Please show me the full output of: time /usr/lib/cups/backend/snmp

Thanks.



Comment 4 Joachim Backes 2006-07-28 04:34:08 UTC
It seems that "time /usr/lib/cups/backend/snmp" hangs or is cpu busy:

INFO: Using default SNMP Address @LOCAL
INFO: Using default SNMP Community public

If I stop it after waiting some time by Ctrl+C, then:

real    1m0.775s
user    0m0.000s
sys     0m0.000s

It consumed a lot of time.

I did a "strace /usr/lib/cups/backend/snmp". The output will be attached.

Comment 5 Joachim Backes 2006-07-28 04:36:17 UTC
Created attachment 133214 [details]
strace /usr/lib/cups/backend/snmp

strace /usr/lib/cups/backend/snmp

Comment 6 Tim Waugh 2006-07-28 15:46:43 UTC
Please try this test update:

https://www.redhat.com/archives/fedora-test-list/2006-July/msg00666.html

You should be able to install this using the command:

  yum --enablerepo=updates-testing 'cups*'

as root.  Does the backend still take a long time?  If so, please show me the
snmp.log from:

  CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp 2>&1 >snmp.log

with the new (1.2.2-1.2) packages installed.  Thanks.

Comment 7 Joachim Backes 2006-07-31 04:58:59 UTC
Hi,

did not help - hangs as before.

The output of CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp >snmp.log 2>&1 has
been attached.

Comment 8 Joachim Backes 2006-07-31 05:01:04 UTC
Created attachment 133304 [details]
CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp >snmp.log 2>&1

Comment 9 Tim Waugh 2006-08-01 13:02:42 UTC
Please try 1.2.2-1.3 from here:

  http://people.redhat.com/twaugh/tmp/cups-snmp/

It contains a small change that I hope will fix it.

Comment 10 Joachim Backes 2006-08-01 13:09:51 UTC
Hi,

I'm sorry, but still hangs. Have attached the output of
CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp

Comment 11 Joachim Backes 2006-08-01 13:10:46 UTC
Created attachment 133395 [details]
CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp

Comment 12 Tim Waugh 2006-08-01 13:54:02 UTC
Hmm.  Please try this:

CUPS_DEBUG_LEVEL=3 strace /usr/lib/cups/backend/snmp 2>&1 | tee snmp.log

and attach the resulting snmp.log.  Thanks.

Comment 13 Joachim Backes 2006-08-02 04:51:34 UTC
Created attachment 133460 [details]
CUPS_DEBUG_LEVEL=3 strace /usr/lib/cups/backend/snmp 2>&1 | tee snmp.log

Comment 14 Tim Waugh 2006-08-02 16:22:02 UTC
Please try 1.2.2-1.4 from here:

  http://people.redhat.com/twaugh/tmp/cups-snmp/

It contains another small change, and hopefully this really is the fix.

Comment 15 Joachim Backes 2006-08-03 04:44:39 UTC
Hi,

you fix seems to solve my problem, but not completely:

The printer adminstration does no more hang - now, I can modify printers by the
"Modify printer" button.

But: trying to modify the printer options by "Set printer options" fails with
the message "Error:

    Not Found

"

I cannot imagine what this message means!

Comment 16 Tim Waugh 2006-08-03 09:10:52 UTC
I think we've finally found the fix to the original problem them (great!).  I've
filed a report about this upstream:

  http://cups.org/str.php?L1880

Please file a separate bugzilla report about the "set printer options" problem,
as it needs to be tracked separately.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.