Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 199920 - Review Request: Palantir
Summary: Review Request: Palantir
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Depends On:
Blocks: FE-DEADREVIEW
TreeView+ depends on / blocked
 
Reported: 2006-07-24 11:18 UTC by Tim Niemueller
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-11-26 18:37:35 UTC


Attachments (Terms of Use)

Description Tim Niemueller 2006-07-24 11:18:34 UTC
Spec URL: http://www.niemueller.de/projects/extrpms/packages/fedora-extras-5/palantir.spec
SRPM URL: http://www.niemueller.de/projects/extrpms/packages/fedora-extras-5/palantir-2.6-1.i386.rpm
Description: A multichannel interactive streaming solution. Allows for streaming webcam audio and video and receiving it with different clients, Java and Qt client are supplied with the package.

Comment 2 Parag AN(पराग) 2006-07-25 03:53:58 UTC
Not able to download SRPM
ERROR 404: Not Found

Comment 3 Tim Niemueller 2006-07-25 08:24:40 UTC
Please try again. It's there now.

Comment 4 Hans de Goede 2006-07-26 15:00:19 UTC
Doesn't build for me as normal user, because it tries to chown installed files:
if [ ! -d /var/tmp/palantir-root/usr/share/palantir ] ; then \
           mkdir -p /var/tmp/palantir-root/usr/share/palantir ; \
           chown root /var/tmp/palantir-root/usr/share/palantir ; \
           fi
chown: changing ownership of `/var/tmp/palantir-root/usr/share/palantir':
Operation not permitted

I guess this can be circumvented for the dir case by first doing an mkdir -p.

Please post a new version with this fixed.


Comment 5 Tim Niemueller 2006-08-08 00:03:13 UTC
New package online at
http://www.niemueller.de/projects/extrpms/packages/fedora-extras-5/palantir-2.6-2.src.rpm
(spec at original URL). All rpmlint warnings have been fixed, scripts have been
updated according to hints given (in the other review requests). The mentioned
problem has been fixed with an extended Makefile patch.

Comment 6 Hans de Goede 2006-08-11 04:52:32 UTC
MUST:
=====
O rpmlint output is:
W: palantir hardcoded-packager-tag Tim
W: palantir redundant-prefix-tag
W: palantir setup-not-quiet
W: palantir mixed-use-of-spaces-and-tabs
These all must be fixed
* Package and spec file named appropriately
* Packaged according to packaging guidelines
* License ok, license file included
* spec file is legible and in Am. English.
* Source matches upstream
* "Compiles" and builds on FC-5 i386
* BR: ok
* No locales
* No shared libraries
* Not relocatable
* Package owns / or requires all dirs
* No duplicate files & Permissions ok
* %clean & macro usage OK
* Contains code only
* %doc does not affect runtime, and isn't large enough to warrent a sub package
* no -devel package needed, no libs / .la files.
* no .desktop file required

MUST fix
========
* rpmlint output:
W: palantir hardcoded-packager-tag Tim
Remove the packager tag
W: palantir redundant-prefix-tag
Remove the prefix tag
W: palantir setup-not-quiet
Add -q to %setup
W: palantir mixed-use-of-spaces-and-tabs
Only uses spaces for indenting, not tabs
* Add: "%defattr(-,root,root,-)" to the subpackages
  %files .
* Source0 must be a full URL

Questions:
==========
* I assume the java client doesn't build with gcj? Have you tried?
* Why is the building of the QT client optional and not done by default, since
  it is in a subpackage the user can always choose to not install it so I would 
  prefer to always build it and atleast build it by default.


Comment 7 Kevin Fenzi 2006-09-02 05:11:11 UTC
Removing FE-NEEDSPONSOR, as submitter was sponsored in: 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=175047

Comment 8 Hans de Goede 2006-10-25 07:58:10 UTC
ping?


Comment 9 Hans de Goede 2006-11-19 07:14:36 UTC
ping again? If I still get no response within one week I'm closing this as a
dead review.



Note You need to log in before you can comment on or make changes to this bug.