Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 199692 - Resume fails when using compiz
Summary: Resume fails when using compiz
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-07-21 13:22 UTC by Bill Nottingham
Modified: 2014-03-17 03:00 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-26 03:33:00 UTC


Attachments (Terms of Use)

Description Bill Nottingham 2006-07-21 13:22:03 UTC
(Feel free to remove yourself from CC if you don't think it's your code. :) )

Resume from suspend hangs when I'm using compiz as the WM when I suspend. It
returns to the text mode (using radeonfb), but then the display locks. It
appears as if the computer is still running, as hitting the power button
starts a graceful shutdown.

Resume when using metacity works OK.

HW notes:
Thinkpad T40p
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 [Mobility
FireGL 9000] (rev 02)

Version-Release number of selected component (if applicable):

kernel-2.6.17-1.2416.fc6
xorg-x11-server-Xorg-1.1.1-6.fc6
xorg-x11-drv-ati-6.6.1-4.1
compiz-0.0.13.fedora1-3
pm-utils-0.19-2

How reproducible:

Every time.

Steps to Reproduce:
1. start-compiz
2. pm-suspend
3. <resume>

Comment 1 Pete Graner 2006-07-21 13:28:02 UTC
I'm seeing the same exact behavior, to include package versions as Bill.

Noticed after 18 July's rawhide update. At that time I thought it was a kernel
thing and waited to update till after the dbus bits were worked out.

Still doing it. I tried with out compiz and used metacity and suspend resume
works as expected.

Comment 2 Bojan Smojver 2006-08-23 20:03:39 UTC
Same here for Dell Inspiron 6400 (Intel 945 graphics). Works fine with metacity.

Packages:

kernel-2.6.17-1.2583.fc6
xorg-x11-server-Xorg-1.1.1-26.fc6
xorg-x11-drv-i810-1.6.5-4.fc6
compiz-0.0.13-0.16.20060817git.fc6
pm-utils-0.19-3

Note that 915resolution is required to run on resume on this machine in order to
get 1680 x 1050. This is done via /etc/pm/hooks/99resolution, which works fine
for metacity:

-----------------------------------
#!/bin/sh

case "$1" in
        thaw|resume)
                { /sbin/service 915resolution start ; } 2>/dev/null
                ;;
        *)
                ;;
esac

exit $?
-----------------------------------

Comment 3 Kristian Høgsberg 2006-08-25 05:30:01 UTC
Please give xorg-x11-server-Xorg-1.1.1-29.fc6 a try.  This build has a fix for
vt switching which should also fix the suspend/resume problems.

Bojan: try using the "intel" driver instead of the "i810" driver - that driver
has the new modesetting code which should be able to set any mode natively.

Comment 4 Bojan Smojver 2006-08-25 06:00:47 UTC
OK, I'll give new Xorg server a go.

BTW, modesetting doesn't work on this Dell machine. Tried it a few times, but no
luck (actually, that's documented in the modesetting Intel driver bug, by me and
others).

Comment 5 Bojan Smojver 2006-08-25 12:08:02 UTC
Yeah, .29 resumes fine with compiz.

Comment 6 Bill Nottingham 2006-08-26 03:33:00 UTC
Works for me with .30.


Note You need to log in before you can comment on or make changes to this bug.