Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 19958 - xscreensaver won't unlock on root password
Summary: xscreensaver won't unlock on root password
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xscreensaver
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
: 76969 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-28 17:44 UTC by Kevin Range
Modified: 2014-03-17 02:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-10-28 17:44:13 UTC


Attachments (Terms of Use)

Description Kevin Range 2000-10-28 17:44:10 UTC
In the xscreensaver man page it says:

Enable  locking:  before the screensaver will turn
               off, it will require you to type the  password  of
               the  logged-in  user  (really,  the person who ran
               xscreensaver), or the root password.

When a user is logged in and locks the screen (or it locks automatically
after the time out), they can enter their password and unlock with no
problem.  But if I try to unlock their screen with the root password it
doesn't work.  So then I have to log in and kill xscreensaver to unlock the
screen.

This isn't a super-big deal, but I imagine in a public lab, this could be a
pain (users leave the screen locked for the afternoon and the sysadmin has
to go around killing xscreensavers...)

Thanks.

Comment 1 Bill Nottingham 2000-10-31 23:48:10 UTC
This is a consequence of the screensaver not being
setuid root, and the use of shadow passwords.

Comment 2 Kevin Range 2000-11-06 22:37:13 UTC
So, not to waste any more of your time, I can understand how shadow passwords
and non-setuid root xscreensaver would cause this problem.  But how does one
solve it?  Make xscreensaver setuid root?  Or does that create other problems?

Thanks for you time.


Comment 3 Bill Nottingham 2002-10-31 03:32:02 UTC
*** Bug 76969 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.