Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 199417 - can't get printer list from ipp server
Summary: can't get printer list from ipp server
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-07-19 14:00 UTC by Karsten Hopp
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-20 11:56:41 UTC


Attachments (Terms of Use)
cupsd.conf (deleted)
2006-07-20 08:41 UTC, Karsten Hopp
no flags Details

Description Karsten Hopp 2006-07-19 14:00:13 UTC
Description of problem:
lp, lpq, kprinter all report that no printers are found. 
The machine next to mine can see all configured printers.

Here are some commands we've tested vi IRC:
#lpstat -r
scheduler is running

#lpstat -s
no system default destination
lpstat: No destinations added.
lpstat: No destinations added.

#tcpdump udp port 631
16:05:19.569772 IP someprintserver.redhat.com.ipp > 255.255.255.255.ipp: UDP,
length 160
16:05:21.569557 IP someprintserver.redhat.com.ipp > 255.255.255.255.ipp: UDP,
length 157
16:05:22.568824 IP someprintserver.redhat.com.ipp > 255.255.255.255.ipp: UDP,
length 143

At the same time in /var/log/cups/error_log:
D [19/Jul/2006:16:05:19 +0200] cupsdNetIFUpdate: "lo" = localhost...
D [19/Jul/2006:16:05:19 +0200] cupsdNetIFUpdate: "eth0" = printclient.redhat.com...
D [19/Jul/2006:16:05:19 +0200] cupsdUpdateCUPSBrowse: Refused 160 bytes from
172.16.x.x
D [19/Jul/2006:16:05:21 +0200] cupsdUpdateCUPSBrowse: Refused 157 bytes from
172.16.x.x
D [19/Jul/2006:16:05:22 +0200] cupsdUpdateCUPSBrowse: Refused 143 bytes from
172.16.x.x

Version-Release number of selected component (if applicable):
cups-1.2.1-18

How reproducible:
always

Comment 3 Tim Waugh 2006-07-19 14:44:36 UTC
Could you attach your /etc/cups/cupsd.conf file please?  I haven't been able to
reproduce this problem here so far.

Comment 4 Karsten Hopp 2006-07-20 08:41:59 UTC
Created attachment 132731 [details]
cupsd.conf

Comment 6 Tim Waugh 2006-07-20 11:51:37 UTC
For the record: the browse packets don't match the local interface's address and
mask because they original outside a local VLAN.

Comment 7 Tim Waugh 2006-07-20 11:56:41 UTC
Reported upstream:

  http://cups.org/str.php?L1854


Note You need to log in before you can comment on or make changes to this bug.