Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 199210 - RuntimeError: could not create GdkPixbuf object
Summary: RuntimeError: could not create GdkPixbuf object
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-display
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-07-17 23:30 UTC by Michael Schwendt
Modified: 2008-08-02 23:40 UTC (History)
3 users (show)

Fixed In Version: 1.0.41-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-26 22:54:35 UTC


Attachments (Terms of Use)
output of system-config-display (deleted)
2006-07-17 23:30 UTC, Michael Schwendt
no flags Details
vc output of system-config-display 1.0.45-1 (deleted)
2006-10-05 13:47 UTC, Michael Schwendt
no flags Details

Description Michael Schwendt 2006-07-17 23:30:00 UTC
Yum update of FC5 to FC Devel leaves me with a non-working X server
and a Python traceback when running s-c-d in virtual console. Full
traceback in separate attachment.

$ rpm -q system-config-display
system-config-display-1.0.37-2

[...]
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 377, in ?
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig,
rhpxl.videocard.VideoCardInfo())
  File "/usr/share/system-config-display/xConfigDialog.py", line 467, in __init__
    self.size_preview =
screenSizePreview.ScreenSizePreview(xml.get_widget("screenshot_darea"),114,86)
  File "/usr/share/system-config-display/screenSizePreview.py", line 58, in __init__
    gtk.gdk.screen_width(), gtk.gdk.screen_height())
RuntimeError: could not create GdkPixbuf object



I've managed to run it with option "--noui" to create a fresh xorg.conf
which results in a lousy VESA 800x600 video mode, because somewhere
there's something else broken and refuses my 1280x1024 mode.

Comment 1 Michael Schwendt 2006-07-17 23:30:00 UTC
Created attachment 132580 [details]
output of system-config-display

Comment 2 Adam Jackson 2006-07-18 13:52:58 UTC
*** Bug 197133 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2006-08-11 15:30:48 UTC
DOes this work better with 1.0.41 in rawhide?

Comment 4 Michael Schwendt 2006-08-11 18:02:16 UTC
Yes.  Now I just need a working mga driver. :(

Comment 5 Michael Schwendt 2006-10-05 13:47:47 UTC
Created attachment 137819 [details]
vc output of system-config-display 1.0.45-1

Startup crash is back:

$ rpm -q system-config-display
system-config-display-1.0.45-1

Comment 6 Adam Jackson 2007-03-26 20:35:41 UTC
I am unable to reproduce this with 1.0.49.  Can you update and verify?

Comment 7 Michael Schwendt 2007-03-26 22:54:35 UTC
1.0.48-1.fc7 is the latest that is available here.

Unable to reproduce.
Cannot reproduce with up-to-date FC6 anymore either.

It's many months since the original report, so I cannot examine
it any further anymore.



Note You need to log in before you can comment on or make changes to this bug.