Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 198987 - Remote printing error
Summary: Remote printing error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 6
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-07-15 11:18 UTC by Anne
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 1.2.2-1.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-27 13:12:09 UTC


Attachments (Terms of Use)
Traffic report between laptop and box with printer attached (deleted)
2006-07-17 13:06 UTC, Anne
no flags Details

Description Anne 2006-07-15 11:18:27 UTC
Description of problem:
Attempting to print to a remote box's printer produces the report
A print error occurred. Error message received from system:

cupsdoprint -P 'Printer' -J 'printcap' -H 'borg.mylan.net:631' -U 'anne' -o ' 
copies=1 multiple-document-handling=separate-documents-collated-copies 
orientation-requested=3' '/tmp/kde-anne/kdeprint_xd8NgsUT' : execution failed 
with message:
client-error-bad-request

Sending from CLI, using lpr -H borg.mylan.net:631 /home/anne/filename.txt produces
lpr: Bad Request

Version-Release number of selected component (if applicable):
Server - cups-1.1.23-15.4
Client - cups-libs-1.2.1-18

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:  FC6t1, updated to the 14/07/06

Comment 1 Tim Waugh 2006-07-17 10:11:58 UTC
I'd like to see exactly what gets sent over the network, so please run this command:

tcpdump -s 0 -U -w traffic.pcap host borg.mylan.net

in one terminal, and then run the 'lpr -H ...' command in another.  When the lpr
command has finished, press control-C in the tcpdump terminal.

Please attach here the traffic.pcap file you end up with.  Thanks!

Comment 2 Anne 2006-07-17 13:06:51 UTC
Created attachment 132544 [details]
Traffic report between laptop and box with printer attached

Comment 3 Tim Waugh 2006-07-17 17:06:14 UTC
Thanks!  This seems to be the same as an issue that has already been reported
upstream:

  http://cups.org/str.php?L1717

I have added your (very useful!) TCP capture file to that report.  It seems to
be that the 'Expect' header has completely confused the older CUPS server and
rather than ignore it, it gives 'bad request'. :-(

Comment 4 Tim Waugh 2006-07-18 14:51:13 UTC
Think I've found the fix.  Awaiting upstream maintainer's opinion on my analysis.

Comment 5 Tim Waugh 2006-07-24 11:41:53 UTC
Please try this test update, 1.2.2-1.1:

https://www.redhat.com/archives/fedora-test-list/2006-July/msg00555.html

You should be able to fetch it using "yum update 'cups*'".

I hope it will solve the problem.

Comment 6 Anne 2006-07-25 20:42:11 UTC
Update installed onto FC6test1, and can confirm that I have just printed a
document across the LAN.  Problem appears to be solved, thanks.


Note You need to log in before you can comment on or make changes to this bug.