Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 198921 - nm-applet asks for access to keychain twice.
Summary: nm-applet asks for access to keychain twice.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target 183737
TreeView+ depends on / blocked
 
Reported: 2006-07-14 16:35 UTC by Wade Mealing
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 0.6.4-5.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-27 18:31:59 UTC


Attachments (Terms of Use)

Description Wade Mealing 2006-07-14 16:35:30 UTC
Description of problem:

Network manager asks twice to unlock the keychain.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.cvs20060529.1

How reproducible:
Every time

Steps to Reproduce:
1. Create initial gnome keychain passphrase
2. log into wireless network, enter wep key, 
3. log out of machine
4. Log back into X11
5. Get prompted twice for nm-applet's access to the keychain
  
Actual results:

Double prompting, and wtfage.

Expected results:

Single prompting.

Additional info:

Could be my wifi, running madwifi-ng here.. doubt it though.

Comment 1 Wade Mealing 2006-07-26 03:40:13 UTC
This behavior changed in todays rawhide, only asks once now.

Closing this bug.

Comment 2 Bill Nottingham 2006-08-07 02:34:14 UTC
This still happens reliably for me with NetworkManager-0.7.0-0.cvs20060529.3.

Comment 3 Christopher Aillon 2006-09-27 03:50:19 UTC
Is this an issue still now that we've reverted to 0.6.4?

Comment 4 Bernard Johnson 2006-09-27 04:07:51 UTC
It's not on mine, however, since I'm not the original reporter, I'll let him
fill the NEEDINFO.

Comment 5 Bill Nottingham 2006-09-27 04:10:28 UTC
I've seen it at least once or twice since then. Will try and reproduce tomorrow.

Comment 6 Bill Nottingham 2006-09-27 18:31:59 UTC
It appears to be working today. Closing.


Note You need to log in before you can comment on or make changes to this bug.