Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 198908 - festival should be built with ESD support.
Summary: festival should be built with ESD support.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: festival
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Miller
QA Contact:
URL:
Whiteboard:
Depends On: festival1.96
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-14 15:34 UTC by karl kleinpaste
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 1.96-0.11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-20 19:01:20 UTC


Attachments (Terms of Use)

Description karl kleinpaste 2006-07-14 15:34:27 UTC
Description of problem:
For some reason, the supplied configuration of festival is to build without ESD
support.  This can be fixed as easily as uncommenting the line "INCLUDE_MODULES
+= ESD_AUDIO" in speech_tools/config/config.in.  I just did a test build that
way and it works fine.  (And now my verbalizing chat system, using festival, no
longer conflicts with xmms &c.)

Version-Release number of selected component (if applicable):
festival-1.95-5.2.i386

How reproducible:
Considering that the build lacks ESD..."every time".

Steps to Reproduce:
Put this in .festivalrc:
(Parameter.def 'Audio_Method 'esdaudio)
  
Actual results:
festival whines about having no compiled ESD support.

Expected results:
um...

Comment 1 Matthew Miller 2007-03-13 05:37:27 UTC
Is ESD still the best approach? Because, y'know, it kinda sucks.

Anyway, I'll change it (in my in-progress package) so support is compiled in.
I'm not sure about making it the default, though.... (Note I'm not officially
the maintainer. But I've been working on this package for a while.)

Comment 2 David Zeuthen 2007-03-13 18:54:31 UTC
esd should not be default at this point (notably we won't have esd running under
gdm and festival will be used there for accessible login)

Comment 3 karl kleinpaste 2007-03-13 19:31:49 UTC
The issue was never making esd a default; rather, it is merely having it built
with esd support enabled, so that esd use is available if wanted.  It costs
nothing to have it compiled into the binary, considering that the support exists
and needs only to be enabled.

Comment 4 Matthew Miller 2007-03-13 19:46:03 UTC
For some reason, enabling the esd module pulls in

MODULE_EXTRA_LIBS += -L$(X11_LIB) -lX11 -lXt

in the makefile.

This is seems pretty silly, so I'm going to try to patch it out. If that doesn't
work, then I'm inclined to let this one sit.

Comment 5 Matthew Miller 2007-03-13 20:58:07 UTC
So, that works. But it turns out that the ESD module defaults to higher priority
than plain Linux audio, so I also had to patch the init.scm to make it not the
default.

It'd be even nicer to make it use esd if it's running and not otherwise. And
possible, too. But I'll save that for another day....

Comment 6 Matthew Miller 2007-03-13 21:20:30 UTC
See bug #232105 for in-progress updated packages which address this issue.

Comment 7 Matthew Miller 2007-03-20 19:01:20 UTC
This issue should be resolved by the release of festival-1.96-0.11, now in the
development tree. (See bug #232105 for details.)

Please reopen if there's still a problem. Thanks.


Note You need to log in before you can comment on or make changes to this bug.