Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 198582 - libgpod lacks the python module it is packaged with
Summary: libgpod lacks the python module it is packaged with
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libgpod
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2006-07-12 02:26 UTC by Jason
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-17 12:18:03 UTC


Attachments (Terms of Use)
.spec with included python bindings (deleted)
2006-08-22 04:00 UTC, Konstantin Ryabitsev
no flags Details

Description Jason 2006-07-12 02:26:50 UTC
Description of problem:
libgpod comes with a python module. ./configure --with-python or --enable-python
(i forget which) will compile a gpod.py module and place it in
/usr/lib/python2.4/site-packages/ This module is missing from the current
libgpod package.

Version-Release number of selected component (if applicable):
rpmlibgpod-0.3.0-2.2.src.rpm

How reproducible:
Open python and import gpod. This will give you a module not found error

Steps to Reproduce:
1. Type python
2. type import gpod
  
Actual results:
[jason@pine ~]$ python
Python 2.4.3 (#1, Jun 13 2006, 11:46:08)
[GCC 4.1.1 20060525 (Red Hat 4.1.1-1)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import gpod
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
ImportError: No module named gpod
>>>


Expected results:
[jason@pine ~]$ python
Python 2.4.3 (#1, Jun 13 2006, 11:46:08)
[GCC 4.1.1 20060525 (Red Hat 4.1.1-1)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import gpod
>>>

Additional info:

Comment 1 Konstantin Ryabitsev 2006-08-22 04:00:51 UTC
Created attachment 134613 [details]
.spec with included python bindings

This .spec (Extras-style) bumps the release to 0.3.2 and includes the Python
bindings. There are some projects that I'd like to include in Extras, but can't
because it's an older version and because it doesn't include python.

This also fixes the "no running ldconfig after installing an .so" bug.

Comment 2 Jef Spaleta 2006-11-13 01:00:03 UTC
This effects fe6 packages now as well as fc5 packages.
In particular the listen application could make use of the python binding to get
ipod access.

Is there any particular reason why this package is lingering in an un updated
state?  

Please pretty please, can we have a status update with regard to the hold-up
with either updating libgpod to the latest version.. or at the very least
enabling the python bindings in the currently available fedora core version.

Is this just a matter of maintainer not having the cycles to deal with this.. or
is there a technical issue I am not aware of that's preventing movement?

-jef


Comment 3 Matthias Clasen 2006-11-20 01:40:36 UTC
libgpod was only packaged because it became an optional rhythmbox dependency a
while ago. For that, we didn't need the python bindings. If there are other apps
which need python bindings for libgpod, we should probably put them in a subpackage.

Comment 4 Todd Zullinger 2006-12-05 05:05:32 UTC
The python module is now available as python-gpod in extras-development. 
If/when libgpod is updated to 0.4.0 or greater in FC[56], the python-gpod
package will get built for FC[56] as well.  If you can poke at the package in
development and report any issues there it would be much appreciated.  BZ
#211648 has more discussion on getting libgpod updated.

Comment 5 Todd Zullinger 2007-01-17 12:18:03 UTC
python-gpod-0.4.2 is now available for FC6 (in Extras).  Please try it out and
report any bugs found against the python-gpod component in bugzilla.


Note You need to log in before you can comment on or make changes to this bug.