Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 198332 - openssh-askpass could not grab keyboard dialog
Summary: openssh-askpass could not grab keyboard dialog
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openssh
Version: 5
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-07-11 06:38 UTC by Ville Ranki
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: openssh-4.3p2-6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-17 14:26:33 UTC


Attachments (Terms of Use)

Description Ville Ranki 2006-07-11 06:38:39 UTC
Description of problem:

The openssh-askpass brought up a scary dialog with text like
"Could not grab keyboard - someone may be eavesdropping you". 
This happened when unlocking screen. I have a directory
mounted over ssh with fuse which wanted to reconnect and
asked for password. 

Anyway the problem is that the dialog is not very informative. 
It doesn't provide info what has caused this (i had to google
for the text to find out it was openssh-askpass) and there
are no instructions how to prevent this. 

I suggest the text is changed to something like 
"SSH password dialog could not grab the keyboard input. 
This might be caused by a bug in a application but also 
someone may be eavesdropping you. Please log out and
log in to prevent this from happening."


Note You need to log in before you can comment on or make changes to this bug.